aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-05-08 19:04:23 +0200
committerMazunki Hoksaas <rolferen@gmail.com>2024-05-08 19:08:01 +0200
commit0f0086abaa630e77bad3a622c7bd39a575456098 (patch)
tree797e0bd4feb65cbdb27e5d15f5e282827ce0f133 /sys-power
parentdev-util/vscode-langservers-extracted: drop 4.7.0 (diff)
downloadguru-0f0086abaa630e77bad3a622c7bd39a575456098.tar.gz
guru-0f0086abaa630e77bad3a622c7bd39a575456098.tar.bz2
guru-0f0086abaa630e77bad3a622c7bd39a575456098.zip
sys-power/amdfan: add 0.1.28
Closes: https://bugs.gentoo.org/931483 Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/amdfan/Manifest1
-rw-r--r--sys-power/amdfan/amdfan-0.1.28.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-power/amdfan/Manifest b/sys-power/amdfan/Manifest
index 69ef6c1a6..e97e1a3cd 100644
--- a/sys-power/amdfan/Manifest
+++ b/sys-power/amdfan/Manifest
@@ -1 +1,2 @@
DIST amdfan-0.1.27.tar.gz 81422 BLAKE2B ab910e8a051f5c8a976425c30c141bc025ecea551f2390e625a36ee767c6a9a106eb4aee9dee5177824d46a2608201888c26672b614972d96598513625db898e SHA512 0a58aea4e53d830470d051292fe966fcf2d5b5094adb9181bf847d7f4467f2fda1e6a87e501c873337b0720ba84a3f7966a92832ed156b96b416107e232b22b0
+DIST amdfan-0.1.28.tar.gz 81901 BLAKE2B 84e461a2f230e560c80badd99ec658774e5b46785a78387d6906d8ebe8a855f1e421a33872246af2a96ff06790615ad47a7d3d248e97a615c78a4ff9de8f641e SHA512 214b4940e747a8c8c0083d1cd90e78a3080e6b6b56031fff42f6bdca867e47ba81defb490e7704786f6e2a2c9634d990d53cbcfbc24c2c43d4ec9691023c06d8
diff --git a/sys-power/amdfan/amdfan-0.1.28.ebuild b/sys-power/amdfan/amdfan-0.1.28.ebuild
new file mode 100644
index 000000000..027f4766a
--- /dev/null
+++ b/sys-power/amdfan/amdfan-0.1.28.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Updated AMD Fan control utility forked from amdgpu-fan and updated. "
+HOMEPAGE="https://mcgillij.dev/pages/amdfan.html"
+SRC_URI="https://github.com/mcgillij/amdfan/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ systemd_dounit src/amdfan/amdfan.service
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover tests || die
+}