aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-02-04 05:53:53 -0500
committerJoe Kappus <joe@wt.gd>2023-02-04 05:55:02 -0500
commit11dcbcffe507dddd4f80cf4bb8282564016776e9 (patch)
treea1fa2b83d44ea84becd3b4c81ea2337125cb0950 /sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
parentapp-shells/antibody: Don't build with -pie when testing (diff)
downloadguru-11dcbcffe507dddd4f80cf4bb8282564016776e9.tar.gz
guru-11dcbcffe507dddd4f80cf4bb8282564016776e9.tar.bz2
guru-11dcbcffe507dddd4f80cf4bb8282564016776e9.zip
sys-power/linux-tools-power-x86: add 6.1, drop py3.8
Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch')
-rw-r--r--sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
new file mode 100644
index 000000000..d0072fe5d
--- /dev/null
+++ b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.1-cflags.patch
@@ -0,0 +1,36 @@
+diff -urN a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-speed-select/Makefile
+--- a/tools/power/x86/intel-speed-select/Makefile 2022-12-11 17:15:18.000000000 -0500
++++ b/tools/power/x86/intel-speed-select/Makefile 2023-02-04 05:47:25.961523494 -0500
+@@ -13,7 +13,7 @@
+ # Do not use make's built-in rules
+ # (this improves performance and avoids hard-to-debug behaviour);
+ MAKEFLAGS += -r
+-override CFLAGS += -O2 -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
++override CFLAGS += -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
+ override LDFLAGS += -lnl-genl-3 -lnl-3
+
+ ALL_TARGETS := intel-speed-select
+diff -urN a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makefile
+--- a/tools/power/x86/turbostat/Makefile 2022-12-11 17:15:18.000000000 -0500
++++ b/tools/power/x86/turbostat/Makefile 2023-02-04 05:49:01.960951027 -0500
+@@ -9,7 +9,7 @@
+ endif
+
+ turbostat : turbostat.c
+-override CFLAGS += -O2 -Wall -Wextra -I../../../include
++override CFLAGS += -Wall -Wextra -I../../../include
+ override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
+ override CFLAGS += -DINTEL_FAMILY_HEADER='"../../../../arch/x86/include/asm/intel-family.h"'
+ override CFLAGS += -D_FILE_OFFSET_BITS=64
+diff -urN a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
+--- a/tools/power/x86/x86_energy_perf_policy/Makefile 2022-12-11 17:15:18.000000000 -0500
++++ b/tools/power/x86/x86_energy_perf_policy/Makefile 2023-02-04 05:47:25.962523488 -0500
+@@ -9,7 +9,7 @@
+ endif
+
+ x86_energy_perf_policy : x86_energy_perf_policy.c
+-override CFLAGS += -O2 -Wall -I../../../include
++override CFLAGS += -Wall -I../../../include
+ override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
+ override CFLAGS += -D_FORTIFY_SOURCE=2
+