aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-01-23 01:20:18 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-01-23 01:20:18 +0100
commitd419b26ec2f246a226daba5f2225c274a540b611 (patch)
tree13462bf98fe6e70fb140599c9e4a95eaf6cecb1b /sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild
parentprofiles: unmask python-manilaclient (diff)
downloadguru-d419b26ec2f246a226daba5f2225c274a540b611.tar.gz
guru-d419b26ec2f246a226daba5f2225c274a540b611.tar.bz2
guru-d419b26ec2f246a226daba5f2225c274a540b611.zip
sys-cluster/portals4: ofed is gone, remove IB transport
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild')
-rw-r--r--sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild b/sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild
new file mode 100644
index 000000000..8aa21c7dc
--- /dev/null
+++ b/sys-cluster/portals4/portals4-1.0_alpha1_p20190109-r3.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="71fc5d04c9f8fc9818a05cdc608e2d13af825d83"
+DOCS_BUILDER="doxygen"
+DOCS_CONFIG_NAME="doxygen.conf"
+DOCS_DIR="doc"
+
+inherit autotools docs optfeature
+
+DESCRIPTION="low-level network API for high-performance networking"
+HOMEPAGE="
+ https://www.cs.sandia.gov/Portals/portals4.html
+ https://github.com/Portals4/portals4
+"
+SRC_URI="https://github.com/Portals4/portals4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE_TRANSPORT="
+ transport-shmem
+ +transport-udp
+"
+IUSE="${IUSE_TRANSPORT} knem me-triggered pmi ppe reliable-udp test unordered-matching zero-mrs"
+
+RDEPEND="
+ dev-libs/libev
+ dev-libs/libxml2
+
+ knem? ( sys-cluster/knem )
+ pmi? ( sys-cluster/pmix[pmi] )
+ ppe? ( sys-kernel/xpmem )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( sys-cluster/pmix[pmi] )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-fix-PPE-related-compile-and-link-errors.patch" )
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ?? ( ppe transport-shmem )
+
+ knem? ( transport-shmem )
+ reliable-udp? ( transport-udp )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-fast
+ --disable-kitten
+ --disable-picky
+ --disable-pmi-from-portals
+ --disable-static
+ --disable-transport-ib
+ --with-ev="${EPREFIX}/usr"
+ --without-ofed
+
+ $(use_enable me-triggered)
+ $(use_enable ppe)
+ $(use_enable reliable-udp)
+ $(use_enable test testing)
+ $(use_enable transport-shmem)
+ $(use_enable transport-udp)
+ $(use_enable unordered-matching)
+ $(use_enable zero-mrs)
+ )
+
+ if use knem; then
+ myconf+=( "--with-knem=${EPREFIX}/usr" )
+ else
+ myconf+=( "--without-knem" )
+ fi
+ if use ppe; then
+ myconf+=( "--with-xpmem=${EPREFIX}/usr" )
+ else
+ myconf+=( "--without-xpmem" )
+ fi
+ if use pmi; then
+ myconf+=( "--with-pmi=${EPREFIX}/usr" )
+ else
+ myconf+=( "--without-pmi" )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "Required for correctness with the IB transport. Ensure that /dev/ummunotify is readable/writable by the user running the portals software." sys-kernel/ummunotify
+}