aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-11-25 23:08:01 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-11-25 23:08:22 +0100
commitfe240c7170b20b52dff5c49351ff9b823f8f5730 (patch)
tree867c28b8c4ebf56b9de174678e4d750f89b1e5db /sys-boot
parentnet-im/fractal: Remove, now in ::gentoo (diff)
downloadguru-fe240c7170b20b52dff5c49351ff9b823f8f5730.tar.gz
guru-fe240c7170b20b52dff5c49351ff9b823f8f5730.tar.bz2
guru-fe240c7170b20b52dff5c49351ff9b823f8f5730.zip
sys-boot/limine: add 5.20231124.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-5.20231124.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 1df133722..9ed95029c 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -7,3 +7,4 @@ DIST limine-4.20230615.0.tar.xz 963720 BLAKE2B a4124be763c84ded9367cffc965ca60c6
DIST limine-5.20230811.0.tar.xz 1289484 BLAKE2B 3044bef68ce62a701df30774d35ce886a6af578e8e1bd943a5524bd9562e8f5709a85800aa5ba4f30a194308b1607a6cea3fedd0951466bf1eef2abb6e462b6c SHA512 6b98ff89efc3e52d2fd36ca1b01818de24ddb512b4936994354ae6604a17738e357ab2a4fcaf81fca97fa8f3499493534fe1e581d8f97ea49c7079d2f5249d2a
DIST limine-5.20231103.0.tar.xz 1349960 BLAKE2B 72348e39ad8cd614e19d88c840580c58b3dbd5d4796f2fb525bb6333bd60d641cb0e3fb2abacbef209637708754a52aadc626c625ae3b548d4d3b3db08e474f1 SHA512 e1a7a5ecfca30bf9246e3e9f6ae92a7f788a9c0f896c408ad0f98de08d76137d18627cbe8c0d9c7b322c6e5674c0a6c1cc0d24a2fb9b082e7e4753988e9f2fd8
DIST limine-5.20231121.0.tar.xz 1366372 BLAKE2B b47b4da7be451d60c6da2c0c0d2df57fce9e767e6ae1b9a59e3e823bfcc492292363560bac70960399d23f5ff6f02ce94985f7f955e18d71c0c48f0e8faa3be7 SHA512 5ab7d0b578af39af0ffb980ecae282431bcaf463a60211d35ed229ef3e1c5f8d9392bbbee64732e70dd87411bedf233e32e953f714cecc44edad4b254221e761
+DIST limine-5.20231124.0.tar.xz 1322812 BLAKE2B 8f15e8a77107a0b49cc58372d59b0fdfedaaaea0c82e46c8e86324e6fee1587f0d878ba77d70f3f24a19cc1a08cd5fc604d21f2252a53fc89f33a0a613874b62 SHA512 af37524f0d59de83f36921939c78421ce864343ef621a4b9ff1437c89080f9ef6467a04ea31f44f3904820dface10703f43b185d11a679bb7536d4573d2295c5
diff --git a/sys-boot/limine/limine-5.20231124.0.ebuild b/sys-boot/limine/limine-5.20231124.0.ebuild
new file mode 100644
index 000000000..73ea27214
--- /dev/null
+++ b/sys-boot/limine/limine-5.20231124.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}