aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-04-07 09:00:35 +0200
committerVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-04-07 09:01:06 +0200
commit857b98c71ac8112fc8f22b399022b357f6290957 (patch)
treefdde10275c14b1ced95925cc013fe5a4d227be5d /sys-auth
parentsci-electronics/kactus2: fix the order of RDEPEND and DEPEND for 3.8.0 (diff)
downloadguru-857b98c71ac8112fc8f22b399022b357f6290957.tar.gz
guru-857b98c71ac8112fc8f22b399022b357f6290957.tar.bz2
guru-857b98c71ac8112fc8f22b399022b357f6290957.zip
sys-auth/AusweisApp2: drop patch
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild5
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-9999.ebuild5
-rw-r--r--sys-auth/AusweisApp2/files/1.20.0-fix-Install.cmake.patch18
3 files changed, 8 insertions, 20 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
index b71dce51e6..0eaaed0ddd 100644
--- a/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
@@ -32,4 +32,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5"
-PATCHES=( "${FILESDIR}"/1.20.0-fix-Install.cmake.patch )
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild b/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
index 5b4754da83..cce70f50d8 100644
--- a/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
+++ b/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
@@ -32,4 +32,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5"
-PATCHES=( "${FILESDIR}"/1.20.0-fix-Install.cmake.patch )
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/files/1.20.0-fix-Install.cmake.patch b/sys-auth/AusweisApp2/files/1.20.0-fix-Install.cmake.patch
deleted file mode 100644
index 9a18e8687b..0000000000
--- a/sys-auth/AusweisApp2/files/1.20.0-fix-Install.cmake.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/cmake/Install.cmake b/cmake/Install.cmake
-index a13e029..336785c 100644
---- a/cmake/Install.cmake
-+++ b/cmake/Install.cmake
-@@ -269,6 +269,13 @@ ELSEIF(ANDROID)
- ELSEIF(UNIX)
- IF(BUILD_SHARED_LIBS)
- SET(CMAKE_INSTALL_RPATH "\$ORIGIN")
-+ INSTALL(TARGETS AusweisAppActivation AusweisAppActivationCustomScheme AusweisAppActivationIntent
-+ AusweisAppActivationInternal AusweisAppActivationWebservice AusweisAppCard AusweisAppCardDrivers
-+ AusweisAppCardPcsc AusweisAppConfiguration AusweisAppCore AusweisAppExport AusweisAppFileProvider
-+ AusweisAppGlobal AusweisAppInit AusweisAppNetwork AusweisAppRemoteDevice AusweisAppSecureStorage
-+ AusweisAppServices AusweisAppSettings AusweisAppUi AusweisAppUiAidl AusweisAppUiCommon
-+ AusweisAppUiJson AusweisAppUiQml AusweisAppUiWebsocket AusweisAppUiWidget AusweisAppWhitelistClient
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} OPTIONAL)
- ENDIF()
-
- SET(DEFAULT_FILE_DESTINATION ${CMAKE_INSTALL_DATADIR}/${VENDOR}/AusweisApp2)