aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Strizhkin <strdenis02@gmail.com>2024-07-15 17:12:12 +0000
committerDenis Strizhkin <strdenis02@gmail.com>2024-07-15 17:13:44 +0000
commita710201075493d8d14a9a651fee44d0d4c600394 (patch)
treed16c7d0c4622f9158ed2a2dc5962928bf62ccd19 /sci-physics
parentnet-wireless/btscreenlocker: new package, add 1.6.1 (diff)
downloadguru-a710201075493d8d14a9a651fee44d0d4c600394.tar.gz
guru-a710201075493d8d14a9a651fee44d0d4c600394.tar.bz2
guru-a710201075493d8d14a9a651fee44d0d4c600394.zip
sci-physics/ovito: fix opengl dep
Signed-off-by: Denis Strizhkin <strdenis02@gmail.com>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/ovito/files/ovito.desktop2
-rw-r--r--sci-physics/ovito/ovito-3.10.5-r1.ebuild42
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-physics/ovito/files/ovito.desktop b/sci-physics/ovito/files/ovito.desktop
index 3f3dfc9aa..c80f7885f 100644
--- a/sci-physics/ovito/files/ovito.desktop
+++ b/sci-physics/ovito/files/ovito.desktop
@@ -3,7 +3,7 @@ Version=1.0
Type=Application
Name=OVITO
Comment=Open Visualization Tool
-Exec=ovito
+Exec=ovito %F
Icon=ovito
Terminal=false
StartupNotify=false
diff --git a/sci-physics/ovito/ovito-3.10.5-r1.ebuild b/sci-physics/ovito/ovito-3.10.5-r1.ebuild
new file mode 100644
index 000000000..b8f8f677a
--- /dev/null
+++ b/sci-physics/ovito/ovito-3.10.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Open Visualization Tool"
+HOMEPAGE="https://www.ovito.org"
+
+ICON="${PN}_icon.png"
+SRC_URI="
+ https://gitlab.com/stuko/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2
+ https://www.ovito.org/wp-content/uploads/logo_rgb-768x737.png -> ${ICON}
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+inherit cmake desktop
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/c-blosc
+ dev-qt/qtbase:6[opengl,gui]
+ dev-qt/qtsvg:6
+ media-video/ffmpeg
+ sci-libs/hdf5
+ sci-libs/netcdf
+"
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ domenu "${FILESDIR}/ovito.desktop"
+ newicon "${DISTDIR}/${ICON}" ovito.png
+}