aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2021-09-04 14:48:24 +0200
committerFrançois-Xavier Carton <fx.carton91@gmail.com>2021-09-04 15:07:39 +0200
commitdab2150f988df03d747f307f497eb0a9dfedbd67 (patch)
treef197a6143ccf0d32d7edc527490992dc879a2588 /sci-mathematics/frama-c-studia
parentsci-mathematics/frama-c: bump to 23.1 (diff)
downloadguru-dab2150f988df03d747f307f497eb0a9dfedbd67.tar.gz
guru-dab2150f988df03d747f307f497eb0a9dfedbd67.tar.bz2
guru-dab2150f988df03d747f307f497eb0a9dfedbd67.zip
sci-mathematics/frama-c: split plugins from main ebuild
USE flags are not meant for this (causing recompilation of everything when changing plugins configuration). In addition, this solves the problem of the main frama-c ebuild having too much USE flags. Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com>
Diffstat (limited to 'sci-mathematics/frama-c-studia')
-rw-r--r--sci-mathematics/frama-c-studia/Manifest1
-rw-r--r--sci-mathematics/frama-c-studia/frama-c-studia-23.1.ebuild45
-rw-r--r--sci-mathematics/frama-c-studia/metadata.xml8
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/frama-c-studia/Manifest b/sci-mathematics/frama-c-studia/Manifest
new file mode 100644
index 000000000..94d4a0a85
--- /dev/null
+++ b/sci-mathematics/frama-c-studia/Manifest
@@ -0,0 +1 @@
+DIST frama-c-23.1-Vanadium.tar.gz 6945715 BLAKE2B aa39c5263c3dd5f407eb97ae56cd734b6209d8dd9b976e67cfa2d3d9879463e47c6ca7b9c4760e111ffa6175e3c8abe698c0bbf7f54098bd7cdd90c704a53e62 SHA512 a96ef705479971991fcdee5440f07c0f30dcf434c7a855cdc894dc03275241599036aa1475b10f062b35045f7749e5d242b930e25ad2fd9e1708e29fca024c9e
diff --git a/sci-mathematics/frama-c-studia/frama-c-studia-23.1.ebuild b/sci-mathematics/frama-c-studia/frama-c-studia-23.1.ebuild
new file mode 100644
index 000000000..071c687e1
--- /dev/null
+++ b/sci-mathematics/frama-c-studia/frama-c-studia-23.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib toolchain-funcs
+
+DESCRIPTION="Studia plugin for frama-c"
+HOMEPAGE="https://frama-c.com"
+NAME="Vanadium"
+SRC_URI="https://frama-c.com/download/frama-c-${PV}-${NAME}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtk +ocamlopt"
+RESTRICT="strip"
+
+RDEPEND="~sci-mathematics/frama-c-${PV}:=[gtk?,ocamlopt?]
+ ~sci-mathematics/frama-c-eva-${PV}:=[gtk?,ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/frama-c-${PV}-${NAME}/src/plugins/studia"
+
+src_prepare() {
+ export FRAMAC_SHARE="${ESYSROOT}/usr/share/frama-c"
+ export FRAMAC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/frama-c"
+ export ENABLE_GUI="$(usex gtk yes no)"
+ eautoconf
+ eapply_user
+}
+
+src_configure() {
+ export ENABLE_EVA=yes
+ econf --enable-studia
+}
+
+src_compile() {
+ tc-export AR
+ emake FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" ENABLE_GUI="${ENABLE_GUI}"
+}
+
+src_install() {
+ emake FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" ENABLE_GUI="${ENABLE_GUI}" DESTDIR="${ED}" install
+}
diff --git a/sci-mathematics/frama-c-studia/metadata.xml b/sci-mathematics/frama-c-studia/metadata.xml
new file mode 100644
index 000000000..e5ed54fe6
--- /dev/null
+++ b/sci-mathematics/frama-c-studia/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>François-Xavier Carton</name>
+ <email>fx.carton91@gmail.com</email>
+ </maintainer>
+</pkgmetadata>