aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2022-01-13 21:33:11 +0100
committerFrançois-Xavier Carton <fx.carton91@gmail.com>2022-01-13 21:35:58 +0100
commitd79091d43727ccec89fc820b59c33ed07c22aa09 (patch)
tree8a2c16d035543698708832c0a0116847a3251e98 /sci-mathematics/frama-c-slicing
parentsci-mathematics/frama-c-wp: add missing variable (diff)
downloadguru-d79091d43727ccec89fc820b59c33ed07c22aa09.tar.gz
guru-d79091d43727ccec89fc820b59c33ed07c22aa09.tar.bz2
guru-d79091d43727ccec89fc820b59c33ed07c22aa09.zip
sci-mathematics/frama-c: bump to 24.0
Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com>
Diffstat (limited to 'sci-mathematics/frama-c-slicing')
-rw-r--r--sci-mathematics/frama-c-slicing/Manifest1
-rw-r--r--sci-mathematics/frama-c-slicing/frama-c-slicing-24.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-mathematics/frama-c-slicing/Manifest b/sci-mathematics/frama-c-slicing/Manifest
index 94d4a0a85..27f9b08b7 100644
--- a/sci-mathematics/frama-c-slicing/Manifest
+++ b/sci-mathematics/frama-c-slicing/Manifest
@@ -1 +1,2 @@
DIST frama-c-23.1-Vanadium.tar.gz 6945715 BLAKE2B aa39c5263c3dd5f407eb97ae56cd734b6209d8dd9b976e67cfa2d3d9879463e47c6ca7b9c4760e111ffa6175e3c8abe698c0bbf7f54098bd7cdd90c704a53e62 SHA512 a96ef705479971991fcdee5440f07c0f30dcf434c7a855cdc894dc03275241599036aa1475b10f062b35045f7749e5d242b930e25ad2fd9e1708e29fca024c9e
+DIST frama-c-24.0-Chromium.tar.gz 7495244 BLAKE2B 249739b55f7d25c75175d31e1703bd3dc160399bc2f10157b09528ec82c7487455b4aef3d248da94e89b7a027c073ad4d8674361899159084e7d84dfa00664a4 SHA512 3ab3070104c7e521c7e94492f85522e6dee4433b1ebed6f5c0d63f4329f8eb66a8f91d467cbd877da138936dfdde1b5b9abcb6bcf01ba0a551fc83c748fac235
diff --git a/sci-mathematics/frama-c-slicing/frama-c-slicing-24.0.ebuild b/sci-mathematics/frama-c-slicing/frama-c-slicing-24.0.ebuild
new file mode 100644
index 000000000..0dcd83814
--- /dev/null
+++ b/sci-mathematics/frama-c-slicing/frama-c-slicing-24.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib toolchain-funcs
+
+DESCRIPTION="Slicing plugin for frama-c"
+HOMEPAGE="https://frama-c.com"
+NAME="Chromium"
+SRC_URI="https://frama-c.com/download/frama-c-${PV}-${NAME}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtk +ocamlopt"
+RESTRICT="strip"
+
+RDEPEND="~sci-mathematics/frama-c-${PV}:=[gtk?,ocamlopt?]
+ ~sci-mathematics/frama-c-callgraph-${PV}:=[gtk?,ocamlopt?]
+ ~sci-mathematics/frama-c-eva-${PV}:=[gtk?,ocamlopt?]
+ ~sci-mathematics/frama-c-pdg-${PV}:=[ocamlopt?]
+ ~sci-mathematics/frama-c-sparecode-${PV}:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/frama-c-${PV}-${NAME}"
+
+src_prepare() {
+ mv configure.in configure.ac || die
+ sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
+ touch config_file || die
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --disable-landmarks \
+ --with-no-plugin \
+ $(use_enable gtk gui) \
+ --enable-slicing \
+ --enable-from-analysis \
+ --enable-callgraph \
+ --enable-eva \
+ --enable-server \
+ --enable-postdominators \
+ --enable-pdg \
+ --enable-sparecode \
+ --enable-users
+ printf 'include share/Makefile.config\n' > src/plugins/slicing/Makefile || die
+ sed -e '/^# *Slicing/bl;d' -e ':l' -e '/^\$(eval/Q;n;bl' < Makefile >> src/plugins/slicing/Makefile || die
+ printf 'include share/Makefile.dynamic\n' >> src/plugins/slicing/Makefile || die
+ export FRAMAC_SHARE="${ESYSROOT}/usr/share/frama-c"
+ export FRAMAC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/frama-c"
+}
+
+src_compile() {
+ tc-export AR
+ emake -f src/plugins/slicing/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}"
+}
+
+src_install() {
+ emake -f src/plugins/slicing/Makefile FRAMAC_SHARE="${FRAMAC_SHARE}" FRAMAC_LIBDIR="${FRAMAC_LIBDIR}" DESTDIR="${ED}" install
+}