aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick J Taylor <patrick.joseph.taylor@gmail.com>2022-09-11 00:37:28 +0100
committerPatrick J Taylor <patrick.joseph.taylor@gmail.com>2022-09-11 00:37:28 +0100
commitd03410871366d089e0888d0743dd438ce4a0f85b (patch)
tree95d0ab2dbad24b6a8f771b4490a18a75db0520bd /sci-chemistry
parentsci-chemistry/xcrysden: add missing dependencies (diff)
downloadguru-d03410871366d089e0888d0743dd438ce4a0f85b.tar.gz
guru-d03410871366d089e0888d0743dd438ce4a0f85b.tar.bz2
guru-d03410871366d089e0888d0743dd438ce4a0f85b.zip
sci-chemistry/vesta-bin: new package, add 3.5.8
Signed-off-by: Patrick J Taylor <patrick.joseph.taylor@gmail.com>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/vesta-bin/Manifest1
-rw-r--r--sci-chemistry/vesta-bin/files/VESTA.desktop8
-rw-r--r--sci-chemistry/vesta-bin/metadata.xml8
-rw-r--r--sci-chemistry/vesta-bin/vesta-bin-3.5.8.ebuild40
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-chemistry/vesta-bin/Manifest b/sci-chemistry/vesta-bin/Manifest
new file mode 100644
index 000000000..eddda12fc
--- /dev/null
+++ b/sci-chemistry/vesta-bin/Manifest
@@ -0,0 +1 @@
+DIST VESTA-gtk3.tar.bz2 24963082 BLAKE2B e3f32358c841ba3dadcb95df68385ef7bd3d004abdd4aad67ad170b04c252318bf49c8bf52eed505277342df22d59d80a1e68440d248c52d08fb12c870c519a2 SHA512 d6ec6ed11a173b899b8d29da0b727f454272e5b3127544c1992a0a8a5a9d4318b0e021230beddd0b43b92cdd5a077a1394dc987dd9dae1b40f00e8ebddef9843
diff --git a/sci-chemistry/vesta-bin/files/VESTA.desktop b/sci-chemistry/vesta-bin/files/VESTA.desktop
new file mode 100644
index 000000000..240692b76
--- /dev/null
+++ b/sci-chemistry/vesta-bin/files/VESTA.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=VESTA
+Type=Application
+Comment=For the visualisation of molecular and crystal structures.
+Exec=VESTA
+TryExec=VESTA
+Icon=/usr/share/icons/hicolor/128x128/apps/VESTA.png
+Categories=Science;
diff --git a/sci-chemistry/vesta-bin/metadata.xml b/sci-chemistry/vesta-bin/metadata.xml
new file mode 100644
index 000000000..50dcf2837
--- /dev/null
+++ b/sci-chemistry/vesta-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick.joseph.taylor@gmail.com</email>
+ <name>Patrick J Taylor</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/vesta-bin/vesta-bin-3.5.8.ebuild b/sci-chemistry/vesta-bin/vesta-bin-3.5.8.ebuild
new file mode 100644
index 000000000..38cf7d8a9
--- /dev/null
+++ b/sci-chemistry/vesta-bin/vesta-bin-3.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Visualisation for Electronic and STructural Analysis."
+
+HOMEPAGE="https://jp-minerals.org/vesta/en/"
+
+SRC_URI="https://jp-minerals.org/vesta/archives/${PV}/VESTA-gtk3.tar.bz2"
+
+S="${WORKDIR}/VESTA-gtk3"
+
+LICENSE="VESTA"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# As of 3.5.6, wayland support required for gtk even when running on xorg.
+RDEPEND=">=x11-libs/gtk+-3.24.34[wayland]
+ >=virtual/glu-9.0-r2
+ >=virtual/jdk-17"
+
+RESTRICT="strip"
+
+src_install() {
+ insinto /opt/VESTA
+ doins -r ${S}/*
+ fperms +x /opt/VESTA/VESTA
+ fperms +x /opt/VESTA/VESTA-gui
+
+ domenu "${FILESDIR}/VESTA.desktop"
+ newicon -s 128x128 ${D}/opt/VESTA/img/logo.png VESTA.png
+
+ dosym /opt/VESTA/libVESTA.so /usr/lib64/libVESTA.so
+ dosym /opt/VESTA/VESTA-gui /usr/bin/VESTA
+}