aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAleksandr Batyuk <abbat.2008@gmail.com>2023-06-27 17:34:32 +0600
committerAleksandr Batyuk <abbat.2008@gmail.com>2023-06-27 17:34:32 +0600
commit9286f51cfddeaa64895f5add3b7a3169abd3119b (patch)
tree1aae8f5d51b281de8c9556699cdf8370ee271f13 /net-wireless
parentscripts/email-checker.py: handle EOF (diff)
downloadguru-9286f51cfddeaa64895f5add3b7a3169abd3119b.tar.gz
guru-9286f51cfddeaa64895f5add3b7a3169abd3119b.tar.bz2
guru-9286f51cfddeaa64895f5add3b7a3169abd3119b.zip
net-wireless/rtl8821ce: Ebuild fix
Signed-off-by: Aleksandr Batyuk <abbat.2008@gmail.com>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/rtl8821ce/rtl8821ce-0_pre20230504.ebuild20
1 files changed, 6 insertions, 14 deletions
diff --git a/net-wireless/rtl8821ce/rtl8821ce-0_pre20230504.ebuild b/net-wireless/rtl8821ce/rtl8821ce-0_pre20230504.ebuild
index bba65298c..179af30c5 100644
--- a/net-wireless/rtl8821ce/rtl8821ce-0_pre20230504.ebuild
+++ b/net-wireless/rtl8821ce/rtl8821ce-0_pre20230504.ebuild
@@ -4,32 +4,24 @@
EAPI=8
inherit linux-mod-r1
-SLOT=0
+MY_PN="rtl8821ce"
COMMIT="a478095a45d8aa957b45be4f9173c414efcacc6f"
-
DESCRIPTION="Realtek RTL8821CE Driver module for Linux kernel"
HOMEPAGE="https://github.com/tomaspinho/rtl8821ce"
-SRC_URI="https://github.com/tomaspinho/rtl8821ce/archive/${COMMIT}.tar.gz -> rtl8821ce-${PV}.tar.gz"
+SRC_URI="https://github.com/tomaspinho/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+SLOT=0
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
-DEPEND="virtual/linux-sources"
-
-S="${WORKDIR}/rtl8821ce-${COMMIT}"
-
CONFIG_CHECK="~!RTW88_8821CE"
ERROR_RTL8XXXU="The RTW88_8821CE module is enabled in the kernel; it conflicts with this module."
src_compile() {
- linux-mod-r1_pkg_setup
-
- local modlist=(8821ce=net/wireless)
+ local modlist=( 8821ce=net/wireless )
+ local modargs=( KSRC="${KV_OUT_DIR}" )
linux-mod-r1_src_compile
}
-
-src_install() {
- linux-mod-r1_src_install
-}