aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-10-29 03:48:12 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-10-29 03:48:12 +0500
commitdf11c5450df888dd49bd4053f35a777848de72d0 (patch)
tree51b76f109fe4c1c9d8c27f8c7fe35cdc32b97921 /net-p2p
parentnet-p2p/yggdrasil-go: sync 9999 with 0.5.9 (diff)
downloadguru-df11c5450df888dd49bd4053f35a777848de72d0.tar.gz
guru-df11c5450df888dd49bd4053f35a777848de72d0.tar.bz2
guru-df11c5450df888dd49bd4053f35a777848de72d0.zip
net-p2p/yggdrasil-go: drop 0.5.7
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/yggdrasil-go/Manifest2
-rw-r--r--net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/net-p2p/yggdrasil-go/Manifest b/net-p2p/yggdrasil-go/Manifest
index 226ea99d6..2fae92444 100644
--- a/net-p2p/yggdrasil-go/Manifest
+++ b/net-p2p/yggdrasil-go/Manifest
@@ -1,4 +1,2 @@
-DIST yggdrasil-go-0.5.7-vendor.tar.xz 1474632 BLAKE2B c10f72f6bc94f07a51af70e55ce693ad140b4b4a1e9a7336bd80e46d6aca759f69c3d339a883732371dc4862e2da6bc4618ba046afe1a1c2efd72b2f5859482d SHA512 64ab1b29686d2c555c7f4fc8a20ea1b4bb40f05e795b010c5536cee5173647c2bcd4fff3b03ff0d8e196b33ffb814a60bdbf7d315fda7d986fdaaa6255d356cb
-DIST yggdrasil-go-0.5.7.tar.gz 107794 BLAKE2B 2baf4689e1ec70362c292a62b67dc944880f6e2ece4f35725b665dc11341c9ccce93433dd085bd41351dd11562c93fd070001b1c83f6b626a5d0606c9ab8c61f SHA512 aeb6668a30043ed1ae695702d21a51faa4acd1dc4c93cbafaf5afd902fdca9a8196ed6e0e2e05b63eba4ea64906b6e43680c79a19f97be8837aa61f161fb48fa
DIST yggdrasil-go-0.5.9-vendor.tar.xz 1396864 BLAKE2B 41e6e0b2f79eca45d59f959385e32ca1059f96c292acfc97b65894b5ac304ddea99b5bf670f27c0431d079beb408ce41bc9a7bbce8591e69a202134e36b51dc0 SHA512 bcb2085845d851e47b566fb7eea77bacd315f2efc22dfc814624793404034f942e180441f42133eeceda6b9f6ba71654df47437c04aba9f25175bc3d88c72b67
DIST yggdrasil-go-0.5.9.tar.gz 109883 BLAKE2B 2a210f5b6d51703e184f7ba48d33cc301c3dc392daf79ef56a42481c46b4d45c996d2c292f685e38bac832efae44dfab4d21a789f259f6c4a4b455850df82793 SHA512 88fb5d6303b1b4a2a611131f939560d08f9d83f3516bf8d1aec041b03cca5e7711e9e989ff14d6f4588e76898b61b3ad51e9f9701837a0bd2235cdaf60e95bb8
diff --git a/net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild b/net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild
deleted file mode 100644
index 608bc194f..000000000
--- a/net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module linux-info systemd
-
-DESCRIPTION="An experiment in scalable routing as an encrypted IPv6 overlay network"
-HOMEPAGE="https://yggdrasil-network.github.io/"
-SRC_URI="
- https://github.com/yggdrasil-network/yggdrasil-go/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://codeberg.org/BratishkaErik/distfiles/releases/download/yggdrasil-go-${PV}/yggdrasil-go-${PV}-vendor.tar.xz
-"
-
-LICENSE="LGPL-3 MIT Apache-2.0 BSD ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-RESTRICT="mirror"
-
-DEPEND="
- acct-user/yggdrasil
- acct-group/yggdrasil
-"
-
-BDEPEND=">=dev-lang/go-1.21"
-
-DOCS=( README.md CHANGELOG.md )
-
-FILECAPS=(
- cap_net_admin,cap_net_bind_service "usr/bin/yggdrasil"
-)
-
-CONFIG_CHECK="~TUN"
-ERROR_TUN="Your kernel lacks TUN support."
-
-src_compile() {
- GOFLAGS+=" -mod=vendor -trimpath"
-
- local ver_config="github.com/yggdrasil-network/yggdrasil-go/src/version"
-
- local custom_name_version_flags="-X ${ver_config}.buildName=${PN}"
- custom_name_version_flags+=" -X ${ver_config}.buildVersion=git-${EGIT_VERSION}"
-
- local GO_LDFLAGS
- GO_LDFLAGS="-s -linkmode external -extldflags \"${LDFLAGS}\" ${custom_name_version_flags}"
-
- local cmd
- for cmd in yggdrasil{,ctl}; do
- ego build ${GOFLAGS} "-ldflags=${GO_LDFLAGS}" ./cmd/"${cmd}"
- done
-}
-
-src_install() {
- dobin yggdrasil{,ctl}
- einstalldocs
-
- systemd_dounit "contrib/systemd/yggdrasil.service"
- systemd_dounit "contrib/systemd/yggdrasil-default-config.service"
- doinitd "contrib/openrc/yggdrasil"
-}