aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Skovorodnikov <victor3.14@yandex.com>2024-08-03 07:33:38 -0700
committerVictor Skovorodnikov <victor3.14@yandex.com>2024-08-03 07:39:58 -0700
commit4a5ccae92cf0ad895423626f09deb7698d1c59f2 (patch)
tree7a8be6ca44add7c37267d28eb3c8da4559d0b289 /net-p2p
parentapp-admin/hardinfo2: add missing deps (diff)
downloadguru-4a5ccae92cf0ad895423626f09deb7698d1c59f2.tar.gz
guru-4a5ccae92cf0ad895423626f09deb7698d1c59f2.tar.bz2
guru-4a5ccae92cf0ad895423626f09deb7698d1c59f2.zip
net-p2p/dogecoin-qt: add 1.14.8
- builds with boost-1.85.0 - c++14 is enabled by default Signed-off-by: Victor Skovorodnikov <victor3.14@yandex.com>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dogecoin-qt/Manifest1
-rw-r--r--net-p2p/dogecoin-qt/dogecoin-qt-1.14.8.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/net-p2p/dogecoin-qt/Manifest b/net-p2p/dogecoin-qt/Manifest
index eee60d209..aab23826d 100644
--- a/net-p2p/dogecoin-qt/Manifest
+++ b/net-p2p/dogecoin-qt/Manifest
@@ -1,2 +1,3 @@
DIST dogecoin-qt-v1.14.6.tar.gz 8162072 BLAKE2B e2d1abe7b60cc2f15998834ec1f23570ad3d471d80e9d05b8e5aa64d6e46b7196d7a13d134e6721fe57b6afd34811bd486de02c00b54ee8516313b81ae6821c2 SHA512 05f1142a22f36a04e65ef91c834b3e724280e29b930617bb66fac98777bb541ddca15771db4205f0cdc14389f3eb4e94fda550f7806b3e9863d909c063f38610
DIST dogecoin-qt-v1.14.7.tar.gz 11546516 BLAKE2B e292983d6fb0ecb35c1d8e45705b38563e3076400aa90b36d5edd0e9adac42d697179362718ed81aead4cb86633d98234b36a46e6e960296abf3029525861c70 SHA512 4febf88cc80565c25a4ec9a809b4ef6a7054d93a57cc0dafbb6f2c2bd8166111507431356227a4c372590450c1c6c80dd365ed666c6a48a04288efdbda74f9f2
+DIST dogecoin-qt-v1.14.8.tar.gz 11572143 BLAKE2B f1ee546eda5eba77234cb4634bf067b4c8d1e2e8ffe11d6265e00909281491f2e68934b4ed9bd2f3f9729294f96f0d192d8b800ace1a725cf517869dcf4d2744 SHA512 e1a401093e86bd2c0b4ef96fcb45bb3dc978eee549cbb39fd09bc8fd6edb699e01ad4f9c2b31a1097beb21ad447841e2693b8503d89567e9d9a50fbf2803de7e
diff --git a/net-p2p/dogecoin-qt/dogecoin-qt-1.14.8.ebuild b/net-p2p/dogecoin-qt/dogecoin-qt-1.14.8.ebuild
new file mode 100644
index 000000000..d7dc39fae
--- /dev/null
+++ b/net-p2p/dogecoin-qt/dogecoin-qt-1.14.8.ebuild
@@ -0,0 +1,144 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WANT_AUTOCONF="2.5"
+inherit autotools desktop xdg-utils flag-o-matic
+DESCRIPTION="Dogecoin Core Qt for desktop. Downloaded blockchain is under 2.2GB. Much secure."
+HOMEPAGE="https://github.com/dogecoin"
+SRC_URI="https://github.com/dogecoin/dogecoin/archive/refs/tags/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+WORKDIR_="${WORKDIR}/dogecoin-${PV}"
+S="${WORKDIR_}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+DB_VER="5.3"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_sse2 intel-avx2 dogecoind experimental +gui +pie +prune scrypt-sse2 +ssp tests utils +wallet zmq"
+REQUIRED_USE="!gui? ( dogecoind utils ) dogecoind? ( utils ) intel-avx2? ( experimental ) scrypt-sse2? ( experimental ) experimental? ( || ( intel-avx2 scrypt-sse2 ) )"
+DOGEDIR="/opt/${PN}"
+DEPEND="
+ sys-libs/db:"${DB_VER}"=[cxx]
+ dev-libs/libevent:=
+ dev-libs/protobuf
+ dev-libs/openssl
+ dev-build/libtool
+ dev-build/automake:=
+ gui? ( dev-qt/qtcore dev-qt/qtgui dev-qt/qtwidgets dev-qt/qtdbus dev-qt/qtnetwork dev-qt/qtprintsupport dev-qt/linguist-tools:= )
+ >=dev-libs/boost-1.84.0
+ wallet? ( media-gfx/qrencode )
+ zmq? ( net-libs/cppzmq )
+"
+
+RDEPEND="${DEPEND}
+ cpu_flags_x86_avx2? (
+ intel-avx2? ( ~app-crypt/intel-ipsec-mb-1.3 )
+ )
+"
+
+BDEPEND="
+ dev-build/autoconf
+ dev-build/automake
+"
+
+pkg_pretend() {
+
+ if use intel-avx2 && [[ ! -e "${ROOT}"/etc/portage/patches/app-crypt/intel-ipsec-mb/remove_digest_init.patch ]]; then
+ eerror "${ROOT}/etc/portage/patches/app-crypt/intel-ipsec-mb/remove_digest_init.patch does not exist!"
+ eerror "To build with avx2 intel support, please create ${ROOT}/etc/portage/patches/app-crypt/intel-ipsec-mb directory"
+ eerror "and copy patch from package net-p2p/dogecoin-qt/files/intel-ipsec-mb/remove_digest_init.patch into that directory"
+ die
+ fi
+}
+
+src_prepare() {
+ if use pie && use ssp ; then
+ PATCHES+=( "${FILESDIR}"/hardened-all.patch )
+ elif use pie && ! use ssp ; then
+ PATCHES+=( "${FILESDIR}"/hardened-no-ssp.patch )
+ elif use ssp && ! use pie ; then
+ PATCHES+=( "${FILESDIR}"/hardened-no-pie.patch )
+ else
+ PATCHES+=( "${FILESDIR}"/hardened-minimal.patch )
+ fi
+
+ default
+
+ einfo "Generating autotools files..."
+ eaclocal -I "${WORKDIR_}"
+ eautoreconf
+}
+
+src_configure() {
+ local my_econf=(
+ --bindir="${DOGEDIR}/bin"
+ --disable-bench
+ --enable-c++14
+ $(use_with gui qt5)
+ $(use_with intel-avx2 intel-avx2)
+ $(use_with dogecoind daemon)
+ $(use_with utils utils)
+ $(use_enable wallet)
+ $(use_enable zmq)
+ $(use_enable tests tests)
+ $(use_enable scrypt-sse2 scrypt-sse2)
+ $(use_enable experimental experimental)
+ )
+
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto "${DOGEDIR}/bin"
+
+ if use gui ; then
+ insinto /usr/share/pixmaps
+ doins src/qt/res/icons/dogecoin.png
+ dosym "${DOGEDIR}/bin/${PN}" "/usr/bin/${PN}"
+
+ if use prune ; then
+ domenu "${FILESDIR}"/"${PN}-prune.desktop"
+ else
+ domenu "${FILESDIR}"/"${PN}.desktop"
+ fi
+ fi
+
+ if use dogecoind ; then
+ dosym "${DOGEDIR}/bin/dogecoind" "/usr/bin/dogecoind"
+ dosym "${DOGEDIR}/bin/dogecoin-cli" "/usr/bin/dogecoin-cli"
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if use gui ; then
+ elog "Dogecoin Core (Qt) ${PV} has been installed."
+ elog "Dogecoin Core (Qt) binaries have been placed in ${DOGEDIR}/bin."
+ elog "${PN} has been symlinked with /usr/bin/${PN}."
+ else
+ elog "Dogecoin Core ${PV} has been installed."
+ elog "Dogecoin Core binaries have been placed in ${DOGEDIR}/bin."
+ fi
+
+ if use dogecoind ; then
+ elog "dogecoin daemon has been symlinked with /usr/bin/dogecoind."
+ elog "dogecoin client utils have been symlinked with /usr/bin/dogecoin-cli."
+ fi
+
+ if ( ( use cpu_flags_x86_avx2 && ! use intel-avx2 ) && ( use cpu_flags_x86_sse2 && ! use scrypt-sse2 ) ); then
+ einfo "NOTE: Experimental avx2 and sse2 CPU support in ${PV} can be"
+ einfo "activated using 'intel-avx2' and/or 'scrypt-sse2' USE flags, "
+ einfo "together with 'experimental' USE flag for this version."
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}