aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@landless-city.net>2024-08-10 17:55:00 +0500
committerEric Joldasov <bratishkaerik@landless-city.net>2024-08-10 17:55:00 +0500
commit23c75da6e33dc701a5adc887bd01e256b36ef5d7 (patch)
treeaa53b83c9c42779d7037001269c922a17d76aabb /net-p2p
parentdev-python/jpype: Add distutils_enable_tests (diff)
downloadguru-23c75da6e33dc701a5adc887bd01e256b36ef5d7.tar.gz
guru-23c75da6e33dc701a5adc887bd01e256b36ef5d7.tar.bz2
guru-23c75da6e33dc701a5adc887bd01e256b36ef5d7.zip
net-p2p/yggdrasil-go: add 0.5.7, drop 0.5.6
Signed-off-by: Eric Joldasov <bratishkaerik@landless-city.net>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/yggdrasil-go/Manifest4
-rw-r--r--net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild (renamed from net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild)10
2 files changed, 7 insertions, 7 deletions
diff --git a/net-p2p/yggdrasil-go/Manifest b/net-p2p/yggdrasil-go/Manifest
index cf0659105d..435e3f2d81 100644
--- a/net-p2p/yggdrasil-go/Manifest
+++ b/net-p2p/yggdrasil-go/Manifest
@@ -1,2 +1,2 @@
-DIST yggdrasil-go-0.5.6-vendor.tar.xz 1434944 BLAKE2B 7abeea0b8a50ec2d2a9dd99842e50912d0e9d4f327dbf5c66c69d2848d219264bef068183e5e80e400f3b187d733cbe708fbc3493f27af1e1922a078f31e1202 SHA512 de555d765155f20e47c742b5dba330ab2659c0a414cbe6c7a3103328f21c8d6a45bb35755c9a1b7c190d4c0aeb2495ca8e1f0ea350b55bec7de405f7b35ecc86
-DIST yggdrasil-go-0.5.6.tar.gz 106181 BLAKE2B 01302cb2a4e08f84bcc33b01e86315a948d0bf6900c2e592edc6cc618ef8d09ea20793ea41ae1ed61ef094a9266a2ff3df840a8ca59c0ba496a03519b8869497 SHA512 1c6f8767000a41d4b4f62c3e6df1e562289b3e699542a2fa99781b74eed2eda7e3c5968f50d068360d72b9308e8e27dfd14f42fd7ff2c63982dd48cc5afd85c2
+DIST yggdrasil-go-0.5.7-vendor.tar.xz 1474632 BLAKE2B c10f72f6bc94f07a51af70e55ce693ad140b4b4a1e9a7336bd80e46d6aca759f69c3d339a883732371dc4862e2da6bc4618ba046afe1a1c2efd72b2f5859482d SHA512 64ab1b29686d2c555c7f4fc8a20ea1b4bb40f05e795b010c5536cee5173647c2bcd4fff3b03ff0d8e196b33ffb814a60bdbf7d315fda7d986fdaaa6255d356cb
+DIST yggdrasil-go-0.5.7.tar.gz 107794 BLAKE2B 2baf4689e1ec70362c292a62b67dc944880f6e2ece4f35725b665dc11341c9ccce93433dd085bd41351dd11562c93fd070001b1c83f6b626a5d0606c9ab8c61f SHA512 aeb6668a30043ed1ae695702d21a51faa4acd1dc4c93cbafaf5afd902fdca9a8196ed6e0e2e05b63eba4ea64906b6e43680c79a19f97be8837aa61f161fb48fa
diff --git a/net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild b/net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild
index 9b6af0f473..608bc194f8 100644
--- a/net-p2p/yggdrasil-go/yggdrasil-go-0.5.6.ebuild
+++ b/net-p2p/yggdrasil-go/yggdrasil-go-0.5.7.ebuild
@@ -34,15 +34,15 @@ CONFIG_CHECK="~TUN"
ERROR_TUN="Your kernel lacks TUN support."
src_compile() {
- local ver_config="github.com/yggdrasil-network/yggdrasil-go/src/version"
+ GOFLAGS+=" -mod=vendor -trimpath"
- local version_disable_detect_flags="-X ${ver_config}.buildName=${PN}"
- version_disable_detect_flags+=" -X ${ver_config}.buildVersion=v${PV}"
+ local ver_config="github.com/yggdrasil-network/yggdrasil-go/src/version"
- GOFLAGS+=" -mod=vendor -trimpath"
+ local custom_name_version_flags="-X ${ver_config}.buildName=${PN}"
+ custom_name_version_flags+=" -X ${ver_config}.buildVersion=git-${EGIT_VERSION}"
local GO_LDFLAGS
- GO_LDFLAGS="-s -linkmode external -extldflags \"${LDFLAGS}\" ${version_disable_detect_flags}"
+ GO_LDFLAGS="-s -linkmode external -extldflags \"${LDFLAGS}\" ${custom_name_version_flags}"
local cmd
for cmd in yggdrasil{,ctl}; do