aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-05-09 09:09:01 -0400
committerAisha Tammy <gentoo@aisha.cc>2021-05-09 09:09:01 -0400
commite76c40c3502ed52ead8791b5b1f7abe47c081df2 (patch)
treee9dcb323f8ec47daff64040b357e72dc34919cff /net-misc
parentnet-misc/purritobin: drop old version (diff)
downloadguru-e76c40c3502ed52ead8791b5b1f7abe47c081df2.tar.gz
guru-e76c40c3502ed52ead8791b5b1f7abe47c081df2.tar.bz2
guru-e76c40c3502ed52ead8791b5b1f7abe47c081df2.zip
net-misc/purritobin: version bump to 0.6.6
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/purritobin/Manifest1
-rw-r--r--net-misc/purritobin/purritobin-0.6.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/purritobin/Manifest b/net-misc/purritobin/Manifest
index 0f9f73a48..946f32cc0 100644
--- a/net-misc/purritobin/Manifest
+++ b/net-misc/purritobin/Manifest
@@ -1 +1,2 @@
DIST purritobin-0.6.5.tar.gz 19431 BLAKE2B 347c683b8281dc5f4792bf06fa84c5e4be32f4a2d91a80727b2b8f30953f70fb30dec9436913f2ad381401fa545ce77f2bb226fd64a0517116fc5853487d3679 SHA512 2257f0d25eb76887834a223ef3a7bdb10e7fe837092618adee3e2887d75be36f0f964edd774b7029c560ea2bf176f0a4d26210f6de4b99ea58bc62352e282683
+DIST purritobin-0.6.6.tar.gz 19433 BLAKE2B 3a54915968baffd53eef3430268047d9c67d6cff226d52e6f514ed456acd62d75c17f091bf0c3f3571a5715c45001c09287dfe591ba1447c7abdfe74e474db67 SHA512 b08fd8c087e7ff95bd980749e0b404836542343ba69808cf2a8aa0915a836272a621de75267e52756e8571bf165158db9d8d0e7c5a5442b10568f4951ada69a9
diff --git a/net-misc/purritobin/purritobin-0.6.6.ebuild b/net-misc/purritobin/purritobin-0.6.6.ebuild
new file mode 100644
index 000000000..2eff4e922
--- /dev/null
+++ b/net-misc/purritobin/purritobin-0.6.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="minimalistic commandline pastebin"
+HOMEPAGE="https://bsd.ac"
+
+inherit systemd meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PurritoBin/PurritoBin.git"
+else
+ SRC_URI="https://github.com/PurritoBin/PurritoBin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PurritoBin-${PV}"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.29
+ net-libs/usockets[ssl]
+ acct-user/purritobin
+ acct-group/purritobin
+"
+DEPEND="${RDEPEND}
+ www-apps/uwebsockets
+ >=dev-db/lmdb++-1.0.0
+"
+BDEPEND="test? ( sys-apps/coreutils )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test enable_testing)
+ -Dtest_dd_flags="iflag=fullblock"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ insinto /var/www/purritobin
+ doins frontend/paste.html
+ keepdir /var/db/purritobin
+ fowners purritobin:purritobin /var/www/purritobin /var/db/purritobin
+ newinitd services/openrc purritobin
+ systemd_newunit services/systemd purritobin.service
+ einstalldocs
+}