aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 02:57:40 +0200
committerGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-07-24 02:57:40 +0200
commit41f2676464f289d1465470ae05fa66ac8513f7e6 (patch)
tree66e40e7d998862ae29df818cd0504713a1f38938 /net-misc
parentnet-misc/eg25-manager: Version bump and remove old (diff)
downloadguru-41f2676464f289d1465470ae05fa66ac8513f7e6.tar.gz
guru-41f2676464f289d1465470ae05fa66ac8513f7e6.tar.bz2
guru-41f2676464f289d1465470ae05fa66ac8513f7e6.zip
net-misc/eg25-manager: Added extra files for configuration
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Gerben jan Dijkman <gjdijkman@gjdwebserver.nl>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/eg25-manager/eg25-manager-0.3.0.ebuild7
-rw-r--r--net-misc/eg25-manager/files/eg25-pinephone-1.0.toml49
-rw-r--r--net-misc/eg25-manager/files/eg25-pinephone-1.1.toml50
-rw-r--r--net-misc/eg25-manager/files/eg25-pinephone-1.2.toml42
4 files changed, 147 insertions, 1 deletions
diff --git a/net-misc/eg25-manager/eg25-manager-0.3.0.ebuild b/net-misc/eg25-manager/eg25-manager-0.3.0.ebuild
index 229397034..bb97e8158 100644
--- a/net-misc/eg25-manager/eg25-manager-0.3.0.ebuild
+++ b/net-misc/eg25-manager/eg25-manager-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,8 +26,13 @@ S="${WORKDIR}/${PN}-${COMMIT}"
src_install() {
meson_src_install
systemd_dounit "${FILESDIR}"/eg25-manager.service
+ insinto /etc/eg25-manager
+ newins "${FILESDIR}"/eg25-pinephone-1.0.toml pine64,pinephone-1.0.toml
+ newins "${FILESDIR}"/eg25-pinephone-1.1.toml pine64,pinephone-1.1.toml
+ newins "${FILESDIR}"/eg25-pinephone-1.2.toml pine64,pinephone-1.2.toml
}
pkg_postinst() {
systemd_reenable --all eg25-manager
}
+
diff --git a/net-misc/eg25-manager/files/eg25-pinephone-1.0.toml b/net-misc/eg25-manager/files/eg25-pinephone-1.0.toml
new file mode 100644
index 000000000..8a3cf4590
--- /dev/null
+++ b/net-misc/eg25-manager/files/eg25-pinephone-1.0.toml
@@ -0,0 +1,49 @@
+[manager]
+need_libusb = true
+usb_vid = 0x2c7c
+usb_pid = 0x0125
+
+# Uncomment the following if you need to change the modem detection timeout on
+# resume and/or the time during which suspend is blocked after modem boot
+#[suspend]
+#boot_timeout = 120
+#recovery_timeout = 9
+
+[gpio]
+dtr = 358
+pwrkey = 35
+reset = 68
+apready = 231
+disable = 232
+
+[at]
+uart = "/dev/ttyS2"
+configure = [
+# Each command has 4 possible elements:
+# * `cmd` : the AT command itself, which will be translated to "AT+`cmd`"
+# * `subcmd`: the subcommand in case a single AT command can be used
+# to change multiple parameters, such as QCFG (optional)
+# * `value` : the commands, argument, usually used to set the value of
+# a specific parameter (optional)
+# * `expect`: the expected return value; the command is first executed
+# without any value in order to query the current state. This
+# state is then compared to the `expect` string; if they don't
+# match, the command is then executed with value `expect` in
+# order to set the parameter to the configured value (optional)
+# A command can have `expect` OR `value` configured, but it shouldn't have both
+ { cmd = "QGMR" },
+ { cmd = "QDAI", expect = "1,1,0,1,0,0,1,1" },
+ { cmd = "QCFG", subcmd = "risignaltype", expect = "\"physical\"" },
+ { cmd = "QCFG", subcmd = "ims", expect = "1" },
+ { cmd = "QCFG", subcmd = "urc/ri/ring", expect = "\"pulse\",2000,1000,5000,\"off\",1" },
+ { cmd = "QCFG", subcmd = "urc/ri/smsincoming", expect = "\"pulse\",2000" },
+ { cmd = "QCFG", subcmd = "urc/ri/other", expect = "\"off\",1" },
+ { cmd = "QCFG", subcmd = "urc/delay", expect = "1" },
+ { cmd = "QURCCFG", subcmd = "urcport", expect = "\"usbat\"" },
+ { cmd = "QSCLK", value = "1" },
+]
+suspend = [
+]
+resume = [
+]
+reset = [ { cmd = "CFUN", value = "1,1" } ]
diff --git a/net-misc/eg25-manager/files/eg25-pinephone-1.1.toml b/net-misc/eg25-manager/files/eg25-pinephone-1.1.toml
new file mode 100644
index 000000000..559ba9110
--- /dev/null
+++ b/net-misc/eg25-manager/files/eg25-pinephone-1.1.toml
@@ -0,0 +1,50 @@
+[manager]
+need_libusb = true
+usb_vid = 0x2c7c
+usb_pid = 0x0125
+
+# Uncomment the following if you need to change the modem detection timeout on
+# resume and/or the time during which suspend is blocked after modem boot
+#[suspend]
+#boot_timeout = 120
+#recovery_timeout = 9
+
+[gpio]
+dtr = 358
+pwrkey = 35
+reset = 68
+apready = 231
+disable = 232
+
+[at]
+uart = "/dev/ttyS2"
+configure = [
+# Each command has 4 possible elements:
+# * `cmd` : the AT command itself, which will be translated to "AT+`cmd`"
+# * `subcmd`: the subcommand in case a single AT command can be used
+# to change multiple parameters, such as QCFG (optional)
+# * `value` : the commands, argument, usually used to set the value of
+# a specific parameter (optional)
+# * `expect`: the expected return value; the command is first executed
+# without any value in order to query the current state. This
+# state is then compared to the `expect` string; if they don't
+# match, the command is then executed with value `expect` in
+# order to set the parameter to the configured value (optional)
+# A command can have `expect` OR `value` configured, but it shouldn't have both
+ { cmd = "QGMR" },
+ { cmd = "QDAI", expect = "1,1,0,1,0,0,1,1" },
+ { cmd = "QCFG", subcmd = "risignaltype", expect = "\"physical\"" },
+ { cmd = "QCFG", subcmd = "ims", expect = "1" },
+ { cmd = "QCFG", subcmd = "urc/ri/ring", expect = "\"pulse\",2000,1000,5000,\"off\",1" },
+ { cmd = "QCFG", subcmd = "urc/ri/smsincoming", expect = "\"pulse\",2000" },
+ { cmd = "QCFG", subcmd = "urc/ri/other", expect = "\"off\",1" },
+ { cmd = "QCFG", subcmd = "urc/delay", expect = "1" },
+ { cmd = "QURCCFG", subcmd = "urcport", expect = "\"usbat\"" },
+ { cmd = "QSCLK", value = "1" },
+]
+suspend = [
+]
+resume = [
+]
+reset = [ { cmd = "CFUN", value = "1,1" } ]
+
diff --git a/net-misc/eg25-manager/files/eg25-pinephone-1.2.toml b/net-misc/eg25-manager/files/eg25-pinephone-1.2.toml
new file mode 100644
index 000000000..109e46892
--- /dev/null
+++ b/net-misc/eg25-manager/files/eg25-pinephone-1.2.toml
@@ -0,0 +1,42 @@
+# Uncomment the following if you need to change the modem detection timeout on
+# resume and/or the time during which suspend is blocked after modem boot
+#[suspend]
+#boot_timeout = 120
+#recovery_timeout = 9
+
+[gpio]
+dtr = 34
+pwrkey = 35
+reset = 68
+apready = 231
+disable = 232
+status = 233
+
+[at]
+uart = "/dev/ttyS2"
+configure = [
+# Each command has 4 possible elements:
+# * `cmd` : the AT command itself, which will be translated to "AT+`cmd`"
+# * `subcmd`: the subcommand in case a single AT command can be used
+# to change multiple parameters, such as QCFG (optional)
+# * `value` : the commands, argument, usually used to set the value of
+# a specific parameter (optional)
+# * `expect`: the expected return value; the command is first executed
+# without any value in order to query the current state. This
+# state is then compared to the `expect` string; if they don't
+# match, the command is then executed with value `expect` in
+# order to set the parameter to the configured value (optional)
+# A command can have `expect` OR `value` configured, but it shouldn't have both
+ { cmd = "QGMR" },
+ { cmd = "QDAI", expect = "1,1,0,1,0,0,1,1" },
+ { cmd = "QCFG", subcmd = "risignaltype", expect = "\"physical\"" },
+ { cmd = "QCFG", subcmd = "ims", expect = "1" },
+ { cmd = "QCFG", subcmd = "apready", expect = "1,0,500" },
+ { cmd = "QURCCFG", subcmd = "urcport", expect = "\"usbat\"" },
+ { cmd = "QSCLK", value = "1" },
+]
+suspend = [
+]
+resume = [
+]
+reset = [ { cmd = "CFUN", value = "1,1" } ]