aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-01-25 10:56:37 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-01-25 12:55:35 +0200
commitd8744e11a690449980a94d3544e0670acf0303b5 (patch)
tree6eaf8734af83487dd0525b09d91c1d8d2e31ba8e /net-misc/maestral
parentdev-python/dropbox-sdk-python: enable py3.11, disable py3.8 (diff)
downloadguru-d8744e11a690449980a94d3544e0670acf0303b5.tar.gz
guru-d8744e11a690449980a94d3544e0670acf0303b5.tar.bz2
guru-d8744e11a690449980a94d3544e0670acf0303b5.zip
net-misc/maestral: enable py3.11, disable py3.8
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/maestral')
-rw-r--r--net-misc/maestral/Manifest2
-rw-r--r--net-misc/maestral/maestral-1.5.3.ebuild31
-rw-r--r--net-misc/maestral/maestral-1.6.5.ebuild21
3 files changed, 21 insertions, 33 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index 993c01468..e38fa58d1 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,2 +1,2 @@
-DIST maestral-1.5.3.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
+DIST maestral-1.5.3.gh.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
DIST maestral-1.6.5.gh.tar.gz 7983512 BLAKE2B b77cc7eb1a6089cc78e47680d99a53bc4c4752feed3970a57e67eefcf1ab2491c0b3aaebd2fb7caf6fc5420eef2e7fe8776e87047f82db7d1466a4c3d17beaf8 SHA512 ee182505b305dbd6730078ce71725eb75515fb5682889c5226c26a69d32f85ad28e335bcd65b57fd1624da8ecd8914df337a93f6b296d86dcc6e94d4f2747995
diff --git a/net-misc/maestral/maestral-1.5.3.ebuild b/net-misc/maestral/maestral-1.5.3.ebuild
index e62609106..178fe7ac2 100644
--- a/net-misc/maestral/maestral-1.5.3.ebuild
+++ b/net-misc/maestral/maestral-1.5.3.ebuild
@@ -3,14 +3,14 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 xdg
DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
HOMEPAGE="https://maestral.app"
-SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -32,29 +32,18 @@ RDEPEND="
>=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
<dev-python/survey-4.0.0[${PYTHON_USEDEP}]
>=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_8)
"
BDEPEND="
dev-python/build[${PYTHON_USEDEP}]
test? ( dev-python/pytest-benchmark[${PYTHON_USEDEP}] )
"
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # this test requires systemd
- sed -i -e 's/test_autostart/_&/' tests/offline/test_cli.py || die
-
- # this test requires network
- sed -i -e 's/test_check_for_updates/_&/' tests/offline/test_main.py || die
+EPYTEST_DESELECT=(
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
- distutils-r1_python_prepare_all
-}
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+)
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
+distutils_enable_tests pytest
diff --git a/net-misc/maestral/maestral-1.6.5.ebuild b/net-misc/maestral/maestral-1.6.5.ebuild
index a540a2de7..6ac6e7773 100644
--- a/net-misc/maestral/maestral-1.6.5.ebuild
+++ b/net-misc/maestral/maestral-1.6.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 xdg
@@ -32,21 +32,20 @@ RDEPEND="
>=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
<dev-python/survey-4.0.0[${PYTHON_USEDEP}]
>=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_8)
"
BDEPEND="
dev-python/build[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-benchmark[${PYTHON_USEDEP}] )
"
-distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # requires dev-python/pytest-benchmark not available for py3.11
+ tests/offline/test_clean_local_events.py::test_performance
-python_prepare_all() {
- # this test requires systemd
- sed -i -e 's/test_autostart/_&/' tests/offline/test_cli.py || die
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
- # this test requires network
- sed -i -e 's/test_check_for_updates/_&/' tests/offline/test_main.py || die
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+)
- distutils-r1_python_prepare_all
-}
+distutils_enable_tests pytest