aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-04 13:42:20 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-04 13:42:20 +0200
commit22c55054aaa11ee3a811d507cddf3e0a30649f6d (patch)
tree20bb7937c1b1f980969dfef75932a078263212c8 /net-misc/maestral
parentsys-devel/just: run tc-export CC (diff)
downloadguru-22c55054aaa11ee3a811d507cddf3e0a30649f6d.tar.gz
guru-22c55054aaa11ee3a811d507cddf3e0a30649f6d.tar.bz2
guru-22c55054aaa11ee3a811d507cddf3e0a30649f6d.zip
net-misc/maestral: add 1.7.0_rc0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/maestral')
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.7.0_rc0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index 7d95b6428..b4c4d4222 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,3 +1,4 @@
DIST maestral-1.5.3.gh.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
DIST maestral-1.6.5.gh.tar.gz 7983512 BLAKE2B b77cc7eb1a6089cc78e47680d99a53bc4c4752feed3970a57e67eefcf1ab2491c0b3aaebd2fb7caf6fc5420eef2e7fe8776e87047f82db7d1466a4c3d17beaf8 SHA512 ee182505b305dbd6730078ce71725eb75515fb5682889c5226c26a69d32f85ad28e335bcd65b57fd1624da8ecd8914df337a93f6b296d86dcc6e94d4f2747995
DIST maestral-1.6.6_rc1.gh.tar.gz 7985890 BLAKE2B e83f63e7bb082bc494e4c3e865a04dede4b969a3f4fc093b714eac7663264d32c0ac9e56b0a7fdb1ffd18d0793c9f22be06145a0890ea4f53057391017bfb148 SHA512 e3ec2612a7dc496a81c6c33de9dc601ed4d78494b2d56652dab2cf2bd5f9dd93fcaea62475662fb7a419769be361f2e8cae67d3706fdbaef3de646e6a0071746
+DIST maestral-1.7.0_rc0.gh.tar.gz 7985893 BLAKE2B 1d3faa9c22f580c90ce0a436a686144ad97e546e5e3ba3aab5f80d8b378259e0e0c89adcd5ef8a789634d751b35496bca4a942d27d7ac24c6cabd190a46834f4 SHA512 a1d7426095bab47a89ed79f4b4c5e5d8848c65324822a3a4a56f482930b58c618ffbf913c6e99925c5ef093917a6d4c5abb52076a3f9122a984ea72a6cb0e8aa
diff --git a/net-misc/maestral/maestral-1.7.0_rc0.ebuild b/net-misc/maestral/maestral-1.7.0_rc0.ebuild
new file mode 100644
index 000000000..bca96dbc6
--- /dev/null
+++ b/net-misc/maestral/maestral-1.7.0_rc0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 xdg
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/dropbox-sdk-python-11.28.0[${PYTHON_USEDEP}]
+ <dev-python/dropbox-sdk-python-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
+ >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
+ >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
+ <dev-python/survey-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ # requires dev-python/pytest-benchmark not available for py3.11
+ tests/offline/test_clean_local_events.py::test_performance
+
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
+
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+)
+
+distutils_enable_tests pytest