aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2024-03-23 20:05:50 -0500
committerbrettalcox <brettalcox@gmail.com>2024-03-23 20:05:50 -0500
commite6477015d3611c3c39c96c2bcd376f7342e98e8f (patch)
treea1f63e6c67b34d875908f62ca7fb26f3eba2ab45 /net-libs
parentapp-editors/pulsar-bin: add 1.115.0, drop 1.113.0 (diff)
downloadguru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.tar.gz
guru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.tar.bz2
guru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.zip
net-libs/syndication-domination: 1.0 / 9999 fixup
Signed-off-by: brettalcox <brettalcox@gmail.com>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/syndication-domination/metadata.xml6
-rw-r--r--net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild (renamed from net-libs/syndication-domination/syndication-domination-1.0.ebuild)10
-rw-r--r--net-libs/syndication-domination/syndication-domination-9999.ebuild6
3 files changed, 11 insertions, 11 deletions
diff --git a/net-libs/syndication-domination/metadata.xml b/net-libs/syndication-domination/metadata.xml
index cc054d261..81cf0cee7 100644
--- a/net-libs/syndication-domination/metadata.xml
+++ b/net-libs/syndication-domination/metadata.xml
@@ -4,16 +4,12 @@
<maintainer type="person">
<email>brettalcox@gmail.com</email>
</maintainer>
- <maintainer type="person">
- <name>Julien Roy</name>
- <email>julien@jroy.ca</email>
- </maintainer>
<upstream>
<remote-id type="gitlab">GabMus/syndication-domination</remote-id>
</upstream>
<use>
<flag name="json-binary">
- Builds a binary executable instead of python bindings
+ Builds a binary executable instead of python bindings
</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/syndication-domination/syndication-domination-1.0.ebuild b/net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild
index 9c6ee2301..caaa6164f 100644
--- a/net-libs/syndication-domination/syndication-domination-1.0.ebuild
+++ b/net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2023-2024 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_11 python3_12 )
inherit meson python-single-r1
@@ -22,7 +22,7 @@ fi
LICENSE="AGPL-3"
SLOT="0"
-IUSE="json-binary +python"
+IUSE="debug json-binary +python"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
!python? ( json-binary )
@@ -43,9 +43,11 @@ RDEPEND="
${DEPEND}
python? ( ${PYTHON_DEPS} )
"
+BDEPEND=""
src_configure() {
- local emesonargs=(
+ EMESON_BUILDTYPE=$(usex debug debug release)
+ local emesonarge=(
--prefix=/usr
-DHTML_SUPPORT=true
$(meson_use python PYTHON_BINDINGS)
diff --git a/net-libs/syndication-domination/syndication-domination-9999.ebuild b/net-libs/syndication-domination/syndication-domination-9999.ebuild
index c3e7342e2..25c303657 100644
--- a/net-libs/syndication-domination/syndication-domination-9999.ebuild
+++ b/net-libs/syndication-domination/syndication-domination-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2023-2024 Gentoo Authors
+# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_11 python3_12 )
inherit meson python-single-r1
@@ -43,8 +43,10 @@ RDEPEND="
${DEPEND}
python? ( ${PYTHON_DEPS} )
"
+BDEPEND=""
src_configure() {
+ EMESON_BUILDTYPE=$(usex debug debug release)
local emesonargs=(
--prefix=/usr
-DHTML_SUPPORT=true