aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-29 06:49:12 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-29 07:07:00 +0500
commit319ee2331969fd6470c1bc6c09393bd99b2d4656 (patch)
treee40835809d8872e591e7f7c37c215635fcd03e5a /net-libs
parentdev-python/rich-click: new package, add 1.8.3 (diff)
downloadguru-319ee2331969fd6470c1bc6c09393bd99b2d4656.tar.gz
guru-319ee2331969fd6470c1bc6c09393bd99b2d4656.tar.bz2
guru-319ee2331969fd6470c1bc6c09393bd99b2d4656.zip
net-libs/kcgi: add 0.13.4, drop old
Closes: https://bugs.gentoo.org/884909 Closes: https://bugs.gentoo.org/921120 Closes: https://bugs.gentoo.org/921122 Closes: https://bugs.gentoo.org/921121 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/kcgi/Manifest3
-rw-r--r--net-libs/kcgi/kcgi-0.12.5.ebuild141
-rw-r--r--net-libs/kcgi/kcgi-0.13.0.ebuild142
-rw-r--r--net-libs/kcgi/kcgi-0.13.4.ebuild92
4 files changed, 93 insertions, 285 deletions
diff --git a/net-libs/kcgi/Manifest b/net-libs/kcgi/Manifest
index 40810127e..66a1ab73d 100644
--- a/net-libs/kcgi/Manifest
+++ b/net-libs/kcgi/Manifest
@@ -1,3 +1,2 @@
-DIST kcgi-0.12.5.tgz 247454 BLAKE2B 1aebd9d62977e22a6a6538b591c40efab53282fd6f28809330c34bfb825798b837003cf0b492f3c3bc79c2ebf3054b466b9e290c156aceee553ef8af6e0a7f07 SHA512 61c28f165b0c1024e4b22fd4e725d79c4e2800b0c6a7fae1473e33608b3299b5ad8630d87ccccaab3e12358dfb6d1c3cd0eb0ed20fa0da1bcc35cc6df8106440
-DIST kcgi-0.13.0.tgz 243127 BLAKE2B e3f4f42450cf3ba5b7f3199e11d1ee57bd2b16f55d662c6989f486811fb49fb1dcba62864320ee1962db5b0cde026db832d6935c14a79f43d4b19383a630f392 SHA512 b07168d87ad55a403120bfe79ac37e29803047bf663bb50ead0a758a1636b9fc77fd3aba45eb52b2f80cd103f1878e861d99e22bc6eefd2dd742ac82f4dbc969
DIST kcgi-0.13.3.tgz 249621 BLAKE2B a503031e8d0cd87eaab7920d1392f51276af723e59baee85a7fd02abfd294d151cc2ccf633207d7e40704fe9d71779d5d8c5582fc28fba02b41b62a924ce7003 SHA512 272ffec2fa31dc465b66c0c67ed5f5e1d9e5ebafbe17e84586299f4a266c1344d127ef04fda284b91a596fc4c6bc06f6e50a784b62bf198c9d3d06c210ae2282
+DIST kcgi-0.13.4.tgz 269175 BLAKE2B 0d19cb6a4ee8bd49968c54ede85abdcd84d05460eed40de3f3445b5fce7e1377612ee5e70877d1261746dffd9c703387c6e3ee32a2ec99b6a8ce0a4874ff9e0b SHA512 070079a015e1bfbb575db16ef6ab40f0c2bbfcc166c83c83b2ac162ed3d5dd82764896b34a5bf125376079cdf040b59ea2bbcdf144d740b829e5113fd81c3a20
diff --git a/net-libs/kcgi/kcgi-0.12.5.ebuild b/net-libs/kcgi/kcgi-0.12.5.ebuild
deleted file mode 100644
index bf6245071..000000000
--- a/net-libs/kcgi/kcgi-0.12.5.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic multilib multiprocessing toolchain-funcs
-
-DESCRIPTION="Minimal CGI library for web applications"
-HOMEPAGE="https://kristaps.bsd.lv/kcgi/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/kristapsdz/${PN}"
-else
- SRC_URI="https://kristaps.bsd.lv/${PN}/snapshots/${P}.tgz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-build/bmake"
-RDEPEND="
- app-crypt/libmd
- virtual/libcrypt
-"
-DEPEND="${RDEPEND}
- test? ( net-misc/curl[static-libs(-)] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-$(ver_cut 1-2)-ldflags.patch )
-
-_get_version_component_count() {
- local cnt=( $(ver_rs 1- ' ') )
- echo ${#cnt[@]} || die
-}
-
-static_to_shared() {
- local libstatic=${1}
- shift
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(ver_cut 1-2))
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
-
- if [[ $(_get_version_component_count) -ge 1 ]] ; then
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(ver_cut 1)) || die
- fi
-
- ln -s ${soname} ${libdir}/${libname}$(get_libname) || die
- fi
-}
-
-src_prepare() {
- default
-
- # disable failing tests
- sed -e '/\s*regress\/test-debug-.*/d' -i Makefile || die
-
- # ld: multiple definition of `dummy'
- local deselect=( sandbox-{capsicum,darwin,pledge,seccomp-filter}.o )
- case ${CHOST} in
- *-linux-*)
- deselect=( "${deselect[@]/sandbox-seccomp-filter.o}" )
- ;;
- *-darwin*)
- deselect=( "${deselect[@]/sandbox-darwin.o}" )
- ;;
- *-freebsd*)
- deselect=( "${deselect[@]/sandbox-capsicum.o}" )
- ;;
- *-openbsd*)
- deselect=( "${deselect[@]/sandbox-pledge.o}" )
- ;;
- esac
-
- for obj in "${deselect[@]}"; do
- # elements are not deleted completely from the array
- if [[ -n "${obj}" ]]; then
- sed "/${obj}/d" -i Makefile || die
- fi
- done
-}
-
-src_configure() {
- tc-export CC AR
- append-cflags -fPIC
-
- # note: not an autoconf configure script
- conf_args=(
- CPPFLAGS="${CPPFLAGS}"
- LDFLAGS="${LDFLAGS}"
- PREFIX="${EPREFIX}"/usr
- MANDIR="${EPREFIX}"/usr/share/man
- LIBDIR="${EPREFIX}"/usr/$(get_libdir)
- SBINDIR="${EPREFIX}"/usr/sbin
- )
- ./configure "${conf_args[@]}" || die
-}
-
-src_compile() {
- bmake -j$(makeopts_jobs) || die
-
- static_to_shared libkcgi.a -lz -lmd
- static_to_shared libkcgihtml.a
- static_to_shared libkcgijson.a -lm
- static_to_shared libkcgiregress.a
- static_to_shared libkcgixml.a
-}
-
-src_test() {
- # TODO: add `afl` tests
- bmake -j$(makeopts_jobs) regress || die
-}
-
-src_install() {
- bmake -j$(makeopts_jobs) \
- DESTDIR="${D}" \
- DATADIR="/usr/share/doc/${PF}/examples" \
- install || die
-
- dolib.so lib*$(get_libname)*
- if ! use static-libs; then
- find "${ED}" -name '*.a' -delete || die
- fi
-
- einstalldocs
-}
diff --git a/net-libs/kcgi/kcgi-0.13.0.ebuild b/net-libs/kcgi/kcgi-0.13.0.ebuild
deleted file mode 100644
index ab44ccc22..000000000
--- a/net-libs/kcgi/kcgi-0.13.0.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic multilib multiprocessing toolchain-funcs
-
-DESCRIPTION="Minimal CGI library for web applications"
-HOMEPAGE="https://kristaps.bsd.lv/kcgi/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/kristapsdz/${PN}"
-else
- SRC_URI="https://kristaps.bsd.lv/${PN}/snapshots/${P}.tgz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-build/bmake"
-RDEPEND="
- app-crypt/libmd
- virtual/libcrypt
-"
-DEPEND="${RDEPEND}
- test? ( net-misc/curl[static-libs(-)] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.12-ldflags.patch )
-
-_get_version_component_count() {
- local cnt=( $(ver_rs 1- ' ') )
- echo ${#cnt[@]} || die
-}
-
-static_to_shared() {
- local libstatic=${1}
- shift
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(ver_cut 1-2))
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
-
- if [[ $(_get_version_component_count) -ge 1 ]] ; then
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(ver_cut 1)) || die
- fi
-
- ln -s ${soname} ${libdir}/${libname}$(get_libname) || die
- fi
-}
-
-src_prepare() {
- default
-
- # ld: multiple definition of `dummy'
- local deselect=( sandbox-{capsicum,darwin,pledge,seccomp-filter}.o )
- case ${CHOST} in
- *-linux-*)
- deselect=( "${deselect[@]/sandbox-seccomp-filter.o}" )
- ;;
- *-darwin*)
- deselect=( "${deselect[@]/sandbox-darwin.o}" )
- ;;
- *-freebsd*)
- deselect=( "${deselect[@]/sandbox-capsicum.o}" )
- ;;
- *-openbsd*)
- deselect=( "${deselect[@]/sandbox-pledge.o}" )
- ;;
- esac
-
- for obj in "${deselect[@]}"; do
- # elements are not deleted completely from the array
- if [[ -n "${obj}" ]]; then
- sed "/${obj}/d" -i Makefile || die
- fi
- done
-}
-
-src_configure() {
- tc-export CC AR
- append-cflags -fPIC
-
- append-cppflags -DENABLE_SECCOMP_FILTER=1
- append-cppflags -DSANDBOX_SECCOMP_DEBUG # seccomp may cause problems
-
- # note: not an autoconf configure script
- conf_args=(
- CPPFLAGS="${CPPFLAGS}"
- LDFLAGS="${LDFLAGS}"
- PREFIX="${EPREFIX}"/usr
- MANDIR="${EPREFIX}"/usr/share/man
- LIBDIR="${EPREFIX}"/usr/$(get_libdir)
- SBINDIR="${EPREFIX}"/usr/sbin
- )
-
- ./configure "${conf_args[@]}" || die
-}
-
-src_compile() {
- bmake -j$(makeopts_jobs) || die
-
- static_to_shared libkcgi.a -lz -lmd
- static_to_shared libkcgihtml.a
- static_to_shared libkcgijson.a -lm
- static_to_shared libkcgiregress.a
- static_to_shared libkcgixml.a
-}
-
-src_test() {
- # TODO: add `afl` tests
- bmake -j$(makeopts_jobs) regress || die
-}
-
-src_install() {
- bmake -j$(makeopts_jobs) \
- DESTDIR="${D}" \
- DATADIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
- install || die
-
- dolib.so lib*$(get_libname)*
- if ! use static-libs; then
- find "${ED}" -name '*.a' -delete || die
- fi
-
- einstalldocs
-}
diff --git a/net-libs/kcgi/kcgi-0.13.4.ebuild b/net-libs/kcgi/kcgi-0.13.4.ebuild
new file mode 100644
index 000000000..b801c9386
--- /dev/null
+++ b/net-libs/kcgi/kcgi-0.13.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Minimal CGI library for web applications"
+HOMEPAGE="https://kristaps.bsd.lv/kcgi/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kristapsdz/${PN}"
+else
+ SRC_URI="https://kristaps.bsd.lv/${PN}/snapshots/${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/libmd
+ dev-libs/libbsd
+ virtual/libcrypt
+"
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/curl
+ sys-libs/zlib
+ )
+"
+BDEPEND="
+ dev-build/bmake
+ virtual/pkgconfig
+ kernel_linux? ( sys-kernel/linux-headers )
+ test? ( net-misc/curl )
+"
+
+# bug 921122
+QA_CONFIG_IMPL_DECL_SKIP=( "*" )
+
+src_prepare() {
+ default
+
+ # bug 921120
+ sed "/CFLAGS=/s/ -g / /" -i configure || die
+}
+
+src_configure() {
+ tc-export CC AR
+ append-cppflags $(usex debug "-DSANDBOX_SECCOMP_DEBUG" "-DNDEBUG")
+
+ # Recommended by upstream
+ append-cflags $(pkg-config --cflags libbsd-overlay)
+ append-ldflags $(pkg-config --libs libbsd-overlay)
+
+ # note: not an autoconf configure script
+ local conf_args=(
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ PREFIX="${EPREFIX}/usr"
+ MANDIR="${EPREFIX}/usr/share/man"
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ SBINDIR="${EPREFIX}/usr/sbin"
+ )
+
+ ./configure "${conf_args[@]}" || die
+}
+
+src_compile() {
+ bmake || die
+}
+
+src_test() {
+ # TODO: add `afl` tests
+ bmake regress || die
+}
+
+src_install() {
+ bmake DESTDIR="${D}" \
+ DATADIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ install || die
+
+ docompress -x /usr/share/doc/${PF}/examples
+ einstalldocs
+
+ # bug 921121
+ find "${ED}"/usr/$(get_libdir) -name "*.a" -delete || die
+}