aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2024-04-15 20:03:54 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2024-04-16 18:27:47 +0200
commitf9cf9f03b7acf55c42cad997585ed360a226cf32 (patch)
tree833c297a9a52567c8bbe549a3f2625914a48b776 /net-dialup
parentapp-misc/watch-tree-and-replace-spaces-with-a-few-other-chars: versiom bump (diff)
downloadguru-f9cf9f03b7acf55c42cad997585ed360a226cf32.tar.gz
guru-f9cf9f03b7acf55c42cad997585ed360a226cf32.tar.bz2
guru-f9cf9f03b7acf55c42cad997585ed360a226cf32.zip
net-dialup/tio: add 2.8
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-2.8.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index c44030836..1ce33f11f 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.7.tar.xz 3432332 BLAKE2B ae6fe436ccc45c22e5cf424cd71fe79c9e467ee13d2c271d122d43afaa1cef3886cd30596bc0acb9ce3fdb57376f23dace3381a3b84b798f3986bbe8aef6a3a5 SHA512 e5e7d32c59693cc95c1af8f909f869868dc361e5add9d184df188d73fb1dd01b5a431aa150a43861e477ebca8d4dc31ae6d7a25f54e63c48c6f13fbb5c8bbb7b
+DIST tio-2.8.tar.xz 3441388 BLAKE2B 934d10f9f91926fae78d4d4c41ddc3ed60e148fea4da81763f052835a993fbf2ebdc4b5d666d9b34ad44f33a8f3c3edd45e14589995dfc0de03254104acb4107 SHA512 b9bac84eb84147a964a504c56dd5aa1ffe706dafc8a7ced4e42a7bb9e1ef262e7f4f015879e5a20b7bfbb1dfe9474bd4ad920b677750b812996b412d05d76272
diff --git a/net-dialup/tio/tio-2.8.ebuild b/net-dialup/tio/tio-2.8.ebuild
new file mode 100644
index 000000000..ee3b4ff0d
--- /dev/null
+++ b/net-dialup/tio/tio-2.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}