aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-12-24 12:14:10 +0100
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-12-24 12:15:02 +0100
commitd23109539193f8c6f51e88894100e2836a42a881 (patch)
treee79c9d2dc8f69bca426cbe8e922ead74e210d54a /net-dialup
parentapp-emulation/quickemu: drop myself as a maintainer (diff)
downloadguru-d23109539193f8c6f51e88894100e2836a42a881.tar.gz
guru-d23109539193f8c6f51e88894100e2836a42a881.tar.bz2
guru-d23109539193f8c6f51e88894100e2836a42a881.zip
net-dialup/tio: add 2.5
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-2.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 8da25f87f..2d60b3daa 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-2.4.tar.xz 3417548 BLAKE2B 15575e603f22a02cbf999916189a0bed8de094b1a3577ae76633169acb4cb8ba1ee62ff37b0c7076dff558f28b371adf7ff55bc896bb752ba7ff0f45bc4068f5 SHA512 397c369a858677479c30034ecd6aba0a4c5ae884473ba191d58e8b5427c58f7cf5215aa9cdf134cac9c78cc67ba2ec6cd92a8a56f755caa465bcd02c1c41018b
+DIST tio-2.5.tar.xz 3418016 BLAKE2B c89765e568122657ee6da1b7a7cc5cfecd4cb44dd1072b79eab1170eba8ff9de5a4797beef122a69e1df46d733ff96973a3ccc0a84b74111e8d528ec50c95d0d SHA512 874fcaa82a182202da0a58ecd41402bb12f3ccb247a21fa77d08283796fd89cf10d8163399f53edd8d675d6c3b21842016066ed976e1855f3e94bf315a686bd1
diff --git a/net-dialup/tio/tio-2.5.ebuild b/net-dialup/tio/tio-2.5.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}