aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2022-07-27 19:02:55 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2022-07-27 19:02:55 +0200
commit06aa9bbd198f98c6907bfbc083130589891b4759 (patch)
tree0f16683d0405569eb5a634fb9f7eff49c06c9c9a /net-dialup
parentwww-servers/hinsightd: add 0.9.15_p20220727, drop old (diff)
downloadguru-06aa9bbd198f98c6907bfbc083130589891b4759.tar.gz
guru-06aa9bbd198f98c6907bfbc083130589891b4759.tar.bz2
guru-06aa9bbd198f98c6907bfbc083130589891b4759.zip
net-dialup/tio: add 1.47
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-1.47.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 154074862..b3e2ac22d 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-1.44.tar.xz 3402220 BLAKE2B e1d0064291587d3c42e8000f0af568c040189e4d3292dfc078b3a8b6caeed16896f4511bb28faaeefeead8b2ae25d9a218fa1953d64181e016879580b95e0c75 SHA512 d4ce4e4dee221a06e8627ac09ff139f81668808ed9ab60bb77b95c7d68b92577aafd3fa7317f34a0386b8d95364fe9198c8d46f7d449e0ee2844fcbdb1b285fa
+DIST tio-1.47.tar.xz 3411172 BLAKE2B b98e50739688fd96ec1b3ec0d58c4c609819c1f7ec56b2ed0ebf2517909070e390f4f69ae344609a4e2e2b6ea61026507bc9fbde4b10b977d5bbe7d4452d4adf SHA512 0fe95f950ab07ff19d7f70bab8ae6474eb0e2e7b6d22dec529450a7c5f02ca746253bee55c35e63b36509c01403c4b92e383b2544959b086e7ce12bb589449ef
diff --git a/net-dialup/tio/tio-1.47.ebuild b/net-dialup/tio/tio-1.47.ebuild
new file mode 100644
index 000000000..aa1af5f4e
--- /dev/null
+++ b/net-dialup/tio/tio-1.47.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/inih
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}