aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-09-07 15:45:02 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-09-13 10:52:23 +0200
commit575528b5cb44386fd4b15e4aad8d802c5e68022c (patch)
treef63613fa36fce4d4fc20b5874d25119de1fca435 /mpv-plugin
parentmpv-plugin/mpv_thumbnail_script: call mpv-plugin_pkg_postinst (diff)
downloadguru-575528b5cb44386fd4b15e4aad8d802c5e68022c.tar.gz
guru-575528b5cb44386fd4b15e4aad8d802c5e68022c.tar.bz2
guru-575528b5cb44386fd4b15e4aad8d802c5e68022c.zip
mpv-plugin/autoload: add 0.36.0
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'mpv-plugin')
-rw-r--r--mpv-plugin/autoload/Manifest1
-rw-r--r--mpv-plugin/autoload/autoload-0.36.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/mpv-plugin/autoload/Manifest b/mpv-plugin/autoload/Manifest
index 6ac1915445..2848b9c4a1 100644
--- a/mpv-plugin/autoload/Manifest
+++ b/mpv-plugin/autoload/Manifest
@@ -1 +1,2 @@
DIST mpv-0.35.1.tar.gz 3367913 BLAKE2B 706a2031a2ca973eb3a092ec7f62ba40ca4dfd78e3ffe5d6e432486b0018852b034152a21805be594054178ccb17856dafe2b860cddcc22d27df895d163871de SHA512 42f3564a9ed4d972d14b2c697b0163f06a8bb68a0606a86c34935181247c783e3cb62286b445799998def0919fb13fce8b8f6453f82652d5bfaea5929119127a
+DIST mpv-0.36.0.tar.gz 3409178 BLAKE2B 7260c265f02918d4caf72d8d8ecc9d4ab9783d66d675bd683a2f9c228404ad978c6fe0aa50f486b5257740176bc26f8abde7eff20d89019d5f701ec78c7743e1 SHA512 51f455a425ea5aac47acb3582d0f958a34248a2290a8d6887d22bcb9385fe8d1ab5d7f09d5408cfecfb73c1ec85d1b8ec8958e45a4941d3f711a2e580187472f
diff --git a/mpv-plugin/autoload/autoload-0.36.0.ebuild b/mpv-plugin/autoload/autoload-0.36.0.ebuild
new file mode 100644
index 0000000000..e46627eca6
--- /dev/null
+++ b/mpv-plugin/autoload/autoload-0.36.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_MPV="rdepend"
+MPV_REQ_USE="lua"
+inherit mpv-plugin
+
+DESCRIPTION="Loads playlist entries before and after the the currently played file"
+HOMEPAGE="https://github.com/mpv-player/mpv/tree/master/TOOLS/lua"
+
+# use the already available mpv tarball
+SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> mpv-${PV}.tar.gz"
+
+# since this comes from mpv, use its licenses
+LICENSE="LGPL-2.1+ GPL-2+ BSD ISC MIT"
+KEYWORDS="~amd64"
+
+# lock mpv version
+RDEPEND="~media-video/mpv-${PV}"
+
+S="${WORKDIR}/mpv-${PV}/TOOLS/lua"
+
+MPV_PLUGIN_FILES=( ${PN}.lua )