aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-08-30 19:47:52 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2023-08-30 19:47:52 +0200
commit57078256a5e7215139f0db1b17dfbbd8540a2fc6 (patch)
treec39d38c76a15139f18a3db2997640798522d64bc /mpv-plugin
parentsys-firmware/lenovolegionlinux: update ebuild for stable version (diff)
downloadguru-57078256a5e7215139f0db1b17dfbbd8540a2fc6.tar.gz
guru-57078256a5e7215139f0db1b17dfbbd8540a2fc6.tar.bz2
guru-57078256a5e7215139f0db1b17dfbbd8540a2fc6.zip
mpv-plugin/mpv-mpris: add version 1.1
Also add new dependency on media-video/ffmpeg to live ebuild. Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'mpv-plugin')
-rw-r--r--mpv-plugin/mpv-mpris/Manifest1
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-1.1.ebuild59
-rw-r--r--mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild1
3 files changed, 61 insertions, 0 deletions
diff --git a/mpv-plugin/mpv-mpris/Manifest b/mpv-plugin/mpv-mpris/Manifest
index a4ae17fc30..457aa97dac 100644
--- a/mpv-plugin/mpv-mpris/Manifest
+++ b/mpv-plugin/mpv-mpris/Manifest
@@ -1,3 +1,4 @@
DIST mpv-mpris-0.8.1.tar.gz 13469 BLAKE2B a284a9ffb7f0c36254bcec6d5cc102e19bca551b02657c1802cc0790e7ce61866b8928fa42e0de483463a05e2e513d90f53477b3fd5ca2cf29c1ce0fe8efc766 SHA512 a7ed2c7d5d0b7eb323026ae7b21c8a55e02a90b9fe761d7162ed7162200cf00793842f04a7a2ac841f7de3196657cfb17029ce7285ea977cd35284879db0184d
DIST mpv-mpris-0.9.tar.gz 13746 BLAKE2B bcfb6efd51265409545e007980774b1ee7b7415fd89788c909be95d0fa12175c8ef9529d18c608345e88b6cba2b11f98a7bcb6cc1977a8b791b7025b6197c269 SHA512 82845320fe8d1ce903e8c9027070339d0281ace3887743728df0c0b4abb12de59bd7e86927d86b2669c54f80fee03d5f65e2c086ddafd5bcf55039db51bf64fc
DIST mpv-mpris-1.0.tar.gz 13974 BLAKE2B fd74326ef24f080505f7da075603b16a44a3c44cebe716ab7c7b013d49e0247e9f4c7b52e842044419a561d3d60cf806682e68343f1f4679e11d562eb8308385 SHA512 edc8218477a3b9b6c0568a122f3c02efde86a4de97f84872b767031e58c6916d4e3b34de75275538e8f18f28f15a139d8fca8631a76cecc04d8df88c457d5fad
+DIST mpv-mpris-1.1.tar.gz 14511 BLAKE2B 17ad84088077748d1604aec0c6777b0edde6cddfe6dc6218f0e41f84547acbcf08b9b92f622345d27754e1300bbada250af0ecf3140885f163df41f99b3c43b5 SHA512 81622e5e34a8ebde735c39a1615569c833d6cf53c70b4f77794788fd8b19982cc33a71ff5768027826dafc608fa72a089e38c0925a907fa249f5c527d17f9541
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-1.1.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-1.1.ebuild
new file mode 100644
index 0000000000..fd71f78d4c
--- /dev/null
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MPV_REQ_USE="cplugins(+),libmpv"
+inherit mpv-plugin toolchain-funcs
+
+DESCRIPTION="MPRIS plugin for mpv"
+HOMEPAGE="https://github.com/hoyon/mpv-mpris"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hoyon/${PN}.git"
+else
+ SRC_URI="https://github.com/hoyon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-video/ffmpeg
+"
+DEPEND="${RDEPEND}"
+# temporary dep for tests on media-video/mpv due to https://github.com/mpv-player/mpv/pull/11468
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ app-misc/jq
+ app-text/jo
+ media-sound/playerctl
+ || (
+ media-video/mpv[lua]
+ media-video/mpv[javascript]
+ >=media-video/mpv-0.36
+ )
+ net-misc/socat
+ sys-apps/dbus
+ x11-apps/xauth
+ x11-misc/xvfb-run
+ x11-themes/sound-theme-freedesktop
+ )
+"
+
+MPV_PLUGIN_FILES=( mpris.so )
+
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ tc-export CC
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_test() {
+ emake test
+}
diff --git a/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
index 64095d3eb8..fd71f78d4c 100644
--- a/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
+++ b/mpv-plugin/mpv-mpris/mpv-mpris-9999.ebuild
@@ -22,6 +22,7 @@ IUSE="test"
RDEPEND="
dev-libs/glib:2
+ media-video/ffmpeg
"
DEPEND="${RDEPEND}"
# temporary dep for tests on media-video/mpv due to https://github.com/mpv-player/mpv/pull/11468