aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Donofrio <justin026@protonmail.com>2024-08-16 21:35:01 -0400
committerJustin Donofrio <justin026@protonmail.com>2024-08-16 21:35:01 -0400
commit3ad33f4902cad41d2e5854733a4d8face71767e0 (patch)
treeec858040b9bbd3e306fc7a26b94189d7a79391e3 /media-video
parentapp-misc/sherlock: new package, add 0.15.0, live (diff)
downloadguru-3ad33f4902cad41d2e5854733a4d8face71767e0.tar.gz
guru-3ad33f4902cad41d2e5854733a4d8face71767e0.tar.bz2
guru-3ad33f4902cad41d2e5854733a4d8face71767e0.zip
media-video/stremio: add 4.4.168
Signed-off-by: Justin Donofrio <justin026@protonmail.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/stremio/Manifest4
-rw-r--r--media-video/stremio/stremio-4.4.168.ebuild69
2 files changed, 73 insertions, 0 deletions
diff --git a/media-video/stremio/Manifest b/media-video/stremio/Manifest
index 7ef9bb334..76ebdfcf7 100644
--- a/media-video/stremio/Manifest
+++ b/media-video/stremio/Manifest
@@ -1 +1,5 @@
+DIST libmpv.gh.tar.gz 31116341 BLAKE2B 65116ed2cbe40137fa71339d8c62e2b20816647f16d00aeff0d18ac5fdfa8d70e1211365d87101796d31af7f42510ce87b791b85222cfdca1a4871e534aced30 SHA512 b8c6155b36b67ff274d379accae40b93f4b0bb3e4dadf01b60b2f4c13fa493b297c1b0c525cdc40b1d74edede8e2804e783beb61f9762be394b68eb6e9aee30a
+DIST razerchroma.gh.tar.gz 20606 BLAKE2B 7764f6f0b9d4f73251f6947dbe3bd7e42f36266e76fe449b600fa57733b1d279cce046c1f7c59b44ec86b7b8caa702011dce424c2071d9722cb0c827edc12ee2 SHA512 e0ace9d6d105f59052b38e475ca7e48ee6e024c850efae54f5e49fe3323399a5e326a8ce69dbd7ff7c9147863a8a4e381daf870534d82e0b259c072c05f6c6d5
DIST server.js 6029535 BLAKE2B 222f8f25d12acf3dae0b861e8fdd01ad29aacb9d46ee381faeb29442eb7f0b21002b6f05f818ed7fc9450e7f22d7afd00c08cf4fd171b7e15949d19d878dee86 SHA512 dbd540c3cf88fd53b36fe424f1fb146cb46c41360d7bf35cdb6ade40d34fb1e93aa33c9b1e3a79ff7a74e6f8202fe3407c9ab28878cfd5a5e373ac5a963fe5c0
+DIST singleapplication.gh.tar.gz 20630 BLAKE2B 0b5f492f50f13e057ccfdd40a82413ecdaaf9060e6f831bed00c2132b22ac78c37f7b682bd3beef17684637d4db57e5410508e48d31d651ad33b6459d156050d SHA512 df0c877c5513efc0f801e6616f28d03ebb3b53c586005a5ca4b1dfd353f7035da6ede23a90d4bbe0378d24895cfdf8edd36718109b7abebf5b3fef59b39a7da3
+DIST stremio-shell.gh.tar.gz 126085979 BLAKE2B b6a92b7bb398b4f250d0f4731b339b34135831e954887c75af776ec2b8f18fbd982efd1367984fcd4699adcdb2b64e50c562c02587d501d5b488f36de1be86a9 SHA512 2920e075cc7de7e134960d85e091e3ee7e2ae87a92bac66632e5be99dc3892560a2c6a7cdd05043e56de067768c58d16db7121edca5e345a4ec2ac73491ca2c2
diff --git a/media-video/stremio/stremio-4.4.168.ebuild b/media-video/stremio/stremio-4.4.168.ebuild
new file mode 100644
index 000000000..32fb39636
--- /dev/null
+++ b/media-video/stremio/stremio-4.4.168.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Stremio is a modern media center for your video entertainment."
+HOMEPAGE="https://github.com/Stremio/stremio-shell/ https://www.stremio.com/"
+SRC_URI="
+ https://github.com/Stremio/stremio-shell/archive/refs/tags/v${PV}.tar.gz -> stremio-shell.gh.tar.gz
+ https://github.com/itay-grudev/SingleApplication/archive/aede311d28d20179216c5419b581087be2a8409f.tar.gz -> singleapplication.gh.tar.gz
+ https://github.com/Ivshti/libmpv/archive/b0eae77cf6dc59aaf142b7d079cb13a0904fd3ee.tar.gz -> libmpv.gh.tar.gz
+ https://github.com/Ivshti/razerchroma/archive/99045142479ba0e2fc3b9cccb72e348c67cd5829.tar.gz -> razerchroma.gh.tar.gz
+ https://dl.strem.io/server/v4.20.8/desktop/server.js
+"
+
+S="${WORKDIR}/${PN}-shell-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="bindist mirror test strip"
+
+RDEPEND="
+ gnome-base/librsvg
+ dev-qt/qtquickcontrols
+ dev-qt/qtopengl
+ dev-qt/qtwebengine:5
+ media-video/ffmpeg[network]
+ media-video/mpv
+ net-libs/nodejs[ssl]
+"
+
+src_compile() {
+ mv ../SingleApplication* ../singleapplication || die
+ mv ../libmpv* ../libmpv || die
+ mv ../razerchroma* ../chroma || die
+
+ mv -t deps \
+ ../singleapplication \
+ ../libmpv \
+ ../chroma || die
+
+ eqmake5
+ emake -f release.makefile
+}
+
+src_install() {
+ insinto /opt/stremio
+ doins build/stremio
+ doins "${DISTDIR}"/server.js
+
+ dosym -r /usr/bin/node /opt/stremio/node
+
+ dosym -r /opt/stremio/stremio /usr/bin/${PN}
+ domenu smartcode-stremio.desktop
+ local x
+ for x in 16 22 24 32 64 128; do
+ newicon -s ${x} icons/smartcode-stremio_${x}.png smartcode-stremio.png
+ done
+
+ fperms +x /opt/stremio/stremio
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}