aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA person <agooglygooglr@gmail.com>2024-06-12 13:28:49 -0400
committerA person <agooglygooglr@gmail.com>2024-06-12 13:28:49 -0400
commit22d8ea44ed2c30544be6d3dd72c0d40b5e460ae5 (patch)
treea2e6629ddaface2bc45723178f8dee890312348b /media-video
parentgames-util/itch-bin: add 26.1.9 (diff)
downloadguru-22d8ea44ed2c30544be6d3dd72c0d40b5e460ae5.tar.gz
guru-22d8ea44ed2c30544be6d3dd72c0d40b5e460ae5.tar.bz2
guru-22d8ea44ed2c30544be6d3dd72c0d40b5e460ae5.zip
media-video/*:
Signed-off-by: A person <agooglygooglr@gmail.com> Add ebuilds for gpu-screen-recorder and it's GUI front-end
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild30
-rw-r--r--media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild42
2 files changed, 72 insertions, 0 deletions
diff --git a/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild b/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild
new file mode 100644
index 000000000..83a466575
--- /dev/null
+++ b/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson git-r3
+
+EGIT_REPO_URI="https://repo.dec05eba.com/gpu-screen-recorder-gtk"
+
+DESCRIPTION="GTK frontend for gpu-screen-recorder."
+HOMEPAGE="https://git.dec05eba.com/gpu-screen-recorder-gtk/about"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+
+DEPEND="
+ x11-libs/gtk+:3
+ dev-libs/libayatana-appindicator
+ media-video/gpu-screen-recorder
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild b/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild
new file mode 100644
index 000000000..bdeefe769
--- /dev/null
+++ b/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson git-r3
+
+EGIT_REPO_URI="https://repo.dec05eba.com/gpu-screen-recorder"
+
+DESCRIPTION="A screen recorder that has minimal impact on system performance, similar to shadowplay on Windows."
+HOMEPAGE="https://git.dec05eba.com/gpu-screen-recorder/about"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+IUSE="+filecaps systemd"
+
+DEPEND="
+ media-video/ffmpeg
+ media-libs/libglvnd
+ x11-libs/libXcomposite
+ x11-libs/libXrandr
+ x11-libs/libXfixes
+ media-libs/libpulse
+ media-libs/libva
+ x11-libs/libdrm
+ sys-libs/libcap
+ dev-libs/wayland
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemd=$(usex filecaps true none)
+ -Dcapabilities=$(usex systemd true none)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}