aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Engel <sighunter@gmx.de>2024-09-21 23:56:56 +0200
committerSebastian Engel <sighunter@gmx.de>2024-09-21 23:56:56 +0200
commita87691ddaa1c68dd6d744b73977918561cf1ae49 (patch)
tree8ee13894adb92f5a8f9baf15ed439dbdae57c19e /media-sound
parentmedia-sound/fooyin: add 0.7.1 (diff)
downloadguru-a87691ddaa1c68dd6d744b73977918561cf1ae49.tar.gz
guru-a87691ddaa1c68dd6d744b73977918561cf1ae49.tar.bz2
guru-a87691ddaa1c68dd6d744b73977918561cf1ae49.zip
media-sound/fooyin: update 9999
Signed-off-by: Sebastian Engel <sighunter@gmx.de>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fooyin/fooyin-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/media-sound/fooyin/fooyin-9999.ebuild b/media-sound/fooyin/fooyin-9999.ebuild
index 00094d24b..96b046b85 100644
--- a/media-sound/fooyin/fooyin-9999.ebuild
+++ b/media-sound/fooyin/fooyin-9999.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="alsa pipewire sdl test"
+IUSE="alsa +archive +openmpt pipewire sdl +sndfile test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
|| ( alsa pipewire sdl )
@@ -32,11 +32,15 @@ RDEPEND="
dev-libs/icu:=
dev-libs/kdsingleapplication
dev-qt/qtbase:6[concurrent,dbus,gui,network,sql,widgets]
+ dev-qt/qtsvg:6
media-libs/taglib
media-video/ffmpeg:=
alsa? ( media-libs/alsa-lib )
+ archive? ( app-arch/libarchive:= )
+ openmpt? ( media-libs/libopenmpt )
pipewire? ( media-video/pipewire:= )
sdl? ( media-libs/libsdl2 )
+ sndfile? ( media-libs/libsndfile )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -59,15 +63,22 @@ src_prepare() {
cmake_src_prepare
}
+# libvgm and libgme dependencies can currently not be satisfied,
+# so building their input plugins is unconditionally disabled for now.
+# SndFile not found though it is enabled, why?
src_configure() {
local mycmakeargs=(
+ -DBUILD_ALSA=$(usex alsa)
-DBUILD_TESTING=$(usex test)
-DBUILD_CCACHE=OFF
-DBUILD_LIBVGM=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_LIBGME=ON
-DINSTALL_HEADERS=ON
- $(cmake_use_find_package alsa ALSA)
+ $(cmake_use_find_package archive LibArchive)
+ $(cmake_use_find_package openmpt OpenMpt)
$(cmake_use_find_package pipewire PipeWire)
$(cmake_use_find_package sdl SDL2)
+ $(cmake_use_find_package sndfile SndFile)
)
cmake_src_configure