aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nicolas <patricknicolas@laposte.net>2024-06-14 17:44:34 +0200
committerPatrick Nicolas <patricknicolas@laposte.net>2024-06-14 17:44:34 +0200
commitf08dc671bbd3efd64c8c8b243be85a8db7b70390 (patch)
tree24f95ebe425c1125b1d177e78ae08a135abfd2f8 /media-libs
parentmedia-libs/wivrn: add 0.16, drop 0.14.1 (diff)
downloadguru-f08dc671bbd3efd64c8c8b243be85a8db7b70390.tar.gz
guru-f08dc671bbd3efd64c8c8b243be85a8db7b70390.tar.bz2
guru-f08dc671bbd3efd64c8c8b243be85a8db7b70390.zip
media-libs/wivrn: add pkg_postinst
Signed-off-by: Patrick Nicolas <patricknicolas@laposte.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/wivrn/wivrn-0.15.ebuild10
-rw-r--r--media-libs/wivrn/wivrn-0.16.ebuild10
-rw-r--r--media-libs/wivrn/wivrn-9999.ebuild10
3 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/wivrn/wivrn-0.15.ebuild b/media-libs/wivrn/wivrn-0.15.ebuild
index d08e16e927..d0cab50c02 100644
--- a/media-libs/wivrn/wivrn-0.15.ebuild
+++ b/media-libs/wivrn/wivrn-0.15.ebuild
@@ -108,3 +108,13 @@ src_install() {
dosym /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
}
+
+pkg_postinst()
+{
+ elog "WiVRn requires a compatible client on VR headset to run."
+ if [[ ${PV} == 9999 ]]; then
+ elog "For most headsets it can be downloaded from CI artifacts on https://github.com/Meumeu/WiVRn/actions/workflows/Build.yml"
+ else
+ elog "For most headsets it can be downloaded on https://github.com/Meumeu/WiVRn/releases/tag/v${PV}"
+ fi
+}
diff --git a/media-libs/wivrn/wivrn-0.16.ebuild b/media-libs/wivrn/wivrn-0.16.ebuild
index 21e51a57d0..d495d12997 100644
--- a/media-libs/wivrn/wivrn-0.16.ebuild
+++ b/media-libs/wivrn/wivrn-0.16.ebuild
@@ -108,3 +108,13 @@ src_install() {
dosym /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
}
+
+pkg_postinst()
+{
+ elog "WiVRn requires a compatible client on VR headset to run."
+ if [[ ${PV} == 9999 ]]; then
+ elog "For most headsets it can be downloaded from CI artifacts on https://github.com/Meumeu/WiVRn/actions/workflows/Build.yml"
+ else
+ elog "For most headsets it can be downloaded on https://github.com/Meumeu/WiVRn/releases/tag/v${PV}"
+ fi
+}
diff --git a/media-libs/wivrn/wivrn-9999.ebuild b/media-libs/wivrn/wivrn-9999.ebuild
index 21e51a57d0..d495d12997 100644
--- a/media-libs/wivrn/wivrn-9999.ebuild
+++ b/media-libs/wivrn/wivrn-9999.ebuild
@@ -108,3 +108,13 @@ src_install() {
dosym /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
}
+
+pkg_postinst()
+{
+ elog "WiVRn requires a compatible client on VR headset to run."
+ if [[ ${PV} == 9999 ]]; then
+ elog "For most headsets it can be downloaded from CI artifacts on https://github.com/Meumeu/WiVRn/actions/workflows/Build.yml"
+ else
+ elog "For most headsets it can be downloaded on https://github.com/Meumeu/WiVRn/releases/tag/v${PV}"
+ fi
+}