aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorVincent Ahluwalia <vincentahluwalia@protonmail.com>2025-01-29 13:08:19 +0100
committerVincent Ahluwalia <vincentahluwalia@protonmail.com>2025-01-29 13:08:22 +0100
commitcbbc7f93ecbec73759b5f23dec23fc4671d6bd7a (patch)
treee6f196c8f38ab98bb7355376b39a5e5872383ec5 /gui-wm
parentgui-libs/libsfdo: new package, add 0.1.3 (diff)
downloadguru-cbbc7f93ecbec73759b5f23dec23fc4671d6bd7a.tar.gz
guru-cbbc7f93ecbec73759b5f23dec23fc4671d6bd7a.tar.bz2
guru-cbbc7f93ecbec73759b5f23dec23fc4671d6bd7a.zip
gui-wm/labwc: new package, add 0.8.1, 0.8.2
Signed-off-by: Vincent Ahluwalia <vincentahluwalia@protonmail.com> new labwc package because the wayland-desktop overlay has been inactive for 4 months now.
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/labwc/Manifest2
-rw-r--r--gui-wm/labwc/files/labwc-meson_doc_path.patch9
-rw-r--r--gui-wm/labwc/labwc-0.8.1.ebuild73
-rw-r--r--gui-wm/labwc/labwc-0.8.2.ebuild73
-rw-r--r--gui-wm/labwc/metadata.xml15
5 files changed, 172 insertions, 0 deletions
diff --git a/gui-wm/labwc/Manifest b/gui-wm/labwc/Manifest
new file mode 100644
index 000000000..bfc0b01c0
--- /dev/null
+++ b/gui-wm/labwc/Manifest
@@ -0,0 +1,2 @@
+DIST labwc-0.8.1.tar.gz 458858 BLAKE2B 4a54f20ef07df7da8612ea911562a86fe619bf94a42eeb222ba72f667acc83c5847521d01500ac8ad33e34863d406d30fc403fce511c96bce6e98d595b3a26f4 SHA512 46c60cefdaae608aa4ab198d66ed405d46291a6b47a2ba0da922240552d157c82e055ecfdecaaaf561ec6951539ecb380801bb8bfdc3eaf7d8c73ae88e41f2b5
+DIST labwc-0.8.2.tar.gz 473740 BLAKE2B addcf8c12dc6c34a6f9e958db40bbfd8f85aec582e0507be1d3d7d2904175d5d1cea480c4ba3365167767e64c02c269ce6b34ad5cf81eec4ae3a34af1123eba8 SHA512 31928cf93225189762a19a288e7469adebdb6b2d5810815d9735bb7f5b0eef3d2e8efa27032f37120c77428e11414fd1b48df357a7832ea78006456dec19d2aa
diff --git a/gui-wm/labwc/files/labwc-meson_doc_path.patch b/gui-wm/labwc/files/labwc-meson_doc_path.patch
new file mode 100644
index 000000000..14db6d27b
--- /dev/null
+++ b/gui-wm/labwc/files/labwc-meson_doc_path.patch
@@ -0,0 +1,9 @@
+--- a/docs/meson.build 2024-07-19 23:06:14.000000000 +0200
++++ b/docs/meson.build 2024-07-20 16:52:29.360804236 +0200
+@@ -35,5 +35,5 @@
+ 'rc.xml',
+ 'rc.xml.all'
+ ],
+- install_dir: get_option('datadir') / 'doc' / meson.project_name()
++ install_dir: get_option('datadir') / 'doc' / meson.project_name() + '-' + meson.project_version()
+ )
diff --git a/gui-wm/labwc/labwc-0.8.1.ebuild b/gui-wm/labwc/labwc-0.8.1.ebuild
new file mode 100644
index 000000000..b07a6c2ca
--- /dev/null
+++ b/gui-wm/labwc/labwc-0.8.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+DESCRIPTION="Openbox alternative for wayland"
+HOMEPAGE="https://github.com/labwc/labwc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/labwc/labwc"
+else
+ SRC_URI="https://github.com/labwc/labwc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="X icons nls svg man static-analyzer test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19
+ dev-libs/glib:2
+ >=dev-libs/libinput-1.14
+ dev-libs/libxml2:2
+ gui-libs/wlroots:0.18[X?]
+ media-libs/libpng
+ x11-libs/cairo[X?]
+ x11-libs/libdrm:=
+ x11-libs/libxkbcommon:=[X?]
+ x11-libs/pango[X?]
+ x11-libs/pixman
+ nls? ( sys-devel/gettext )
+ svg? ( >=gnome-base/librsvg-2.46 )
+ X? ( x11-libs/libxcb:0= )
+ X? ( x11-base/xwayland )
+ icons? ( gui-libs/libsfdo )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+ test? ( dev-util/cmocka )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-meson_doc_path.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature X xwayland)
+ $(meson_feature nls)
+ $(meson_feature svg)
+ $(meson_feature icons icon)
+ $(meson_feature man man-pages)
+ $(meson_feature test)
+ $(meson_feature static-analyzer static_analyzer)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/gui-wm/labwc/labwc-0.8.2.ebuild b/gui-wm/labwc/labwc-0.8.2.ebuild
new file mode 100644
index 000000000..4bfd56a08
--- /dev/null
+++ b/gui-wm/labwc/labwc-0.8.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+DESCRIPTION="Openbox alternative for wayland"
+HOMEPAGE="https://github.com/labwc/labwc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/labwc/labwc"
+else
+ SRC_URI="https://github.com/labwc/labwc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="X icons nls svg man static-analyzer test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19
+ dev-libs/glib:2
+ >=dev-libs/libinput-1.14
+ dev-libs/libxml2:2
+ >=gui-libs/wlroots-0.18.1[X?]
+ media-libs/libpng
+ x11-libs/cairo[X?]
+ x11-libs/libdrm:=
+ x11-libs/libxkbcommon:=[X?]
+ x11-libs/pango[X?]
+ x11-libs/pixman
+ nls? ( sys-devel/gettext )
+ svg? ( >=gnome-base/librsvg-2.46 )
+ X? ( x11-libs/libxcb:0= )
+ X? ( x11-base/xwayland )
+ icons? ( gui-libs/libsfdo )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+ test? ( dev-util/cmocka )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-meson_doc_path.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature X xwayland)
+ $(meson_feature nls)
+ $(meson_feature svg)
+ $(meson_feature icons icon)
+ $(meson_feature man man-pages)
+ $(meson_feature test)
+ $(meson_feature static-analyzer static_analyzer)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/gui-wm/labwc/metadata.xml b/gui-wm/labwc/metadata.xml
new file mode 100644
index 000000000..6748ced16
--- /dev/null
+++ b/gui-wm/labwc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vincentahluwalia@protonmail.com</email>
+ <name>Vincent Ahluwalia</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">labwc/labwc</remote-id>
+ </upstream>
+ <use>
+ <flag name="icons">Add support for window icons. Icons will only be displayed with USE=svg enabled</flag>
+ <flag name="static-analyzer">Run gcc static analyzer</flag>
+ </use>
+</pkgmetadata>