aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuhang Zeng <unlsycn@unlsycn.com>2024-08-01 23:19:33 +0800
committerYuhang Zeng <unlsycn@unlsycn.com>2024-08-01 23:22:09 +0800
commit139ec0f733978e3a123742a23ac96b43230139d6 (patch)
treea95ca36010ecacb3f5038183add0340d1237c6bf /gui-libs
parentmedia-sound/wlavu: remove ghost package (diff)
downloadguru-139ec0f733978e3a123742a23ac96b43230139d6.tar.gz
guru-139ec0f733978e3a123742a23ac96b43230139d6.tar.bz2
guru-139ec0f733978e3a123742a23ac96b43230139d6.zip
gui-libs/gtk4-layer-shell: new package, add 1.0.2
Signed-off-by: Yuhang Zeng <unlsycn@unlsycn.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtk4-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk4-layer-shell/gtk4-layer-shell-1.0.2.ebuild49
-rw-r--r--gui-libs/gtk4-layer-shell/metadata.xml17
3 files changed, 67 insertions, 0 deletions
diff --git a/gui-libs/gtk4-layer-shell/Manifest b/gui-libs/gtk4-layer-shell/Manifest
new file mode 100644
index 000000000..3c0defdc0
--- /dev/null
+++ b/gui-libs/gtk4-layer-shell/Manifest
@@ -0,0 +1 @@
+DIST gtk4-layer-shell-1.0.2.tar.gz 62997 BLAKE2B 9fae09ce33b983e6e8a620069b18fbd36211bf80a13d7100669cd458571664773cbc3ee08c2d15b51085653658b9425c634656a393eaf0f7254a2d54df22180a SHA512 f43a75c20fa41e4bc44430a36cf60a01281ce67a19afb4ed8297633a91803394ba8fe14dfb81db46f5bccc3e3dfe1474175b6c3249cfa614b42b167329b279f3
diff --git a/gui-libs/gtk4-layer-shell/gtk4-layer-shell-1.0.2.ebuild b/gui-libs/gtk4-layer-shell/gtk4-layer-shell-1.0.2.ebuild
new file mode 100644
index 000000000..c954b6718
--- /dev/null
+++ b/gui-libs/gtk4-layer-shell/gtk4-layer-shell-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A library for using the Layer Shell Wayland protocol with GTK4."
+HOMEPAGE="https://github.com/wmww/gtk4-layer-shell"
+SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="examples doc test smoke-tests introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RESTRICT="!test? ( test )"
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit meson python-any-r1
+
+DEPEND="
+ >=gui-libs/gtk-4.10.5[wayland]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-build/meson-0.45.1
+ >=dev-build/ninja-1.8.2
+ introspection? ( dev-libs/gobject-introspection )
+ doc? ( dev-util/gtk-doc )
+ test? ( >=dev-lang/python-3.8.19 )
+ vala? ( dev-lang/vala )
+ smoke-tests? (
+ dev-lang/luajit
+ dev-lua/lgi
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use doc docs)
+ $(meson_use test tests)
+ $(meson_use smoke-tests)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/gtk4-layer-shell/metadata.xml b/gui-libs/gtk4-layer-shell/metadata.xml
new file mode 100644
index 000000000..0287e6b62
--- /dev/null
+++ b/gui-libs/gtk4-layer-shell/metadata.xml
@@ -0,0 +1,17 @@
+<pkgmetadata>
+ <maintainer type="person">
+ <email>unlsycn@unlsycn.com</email>
+ <name>unlsycn</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wmww/gtk4-layer-shell</remote-id>
+ </upstream>
+ <longdescription lang="en">A library to create panels and other desktop components for Wayland using the Layer Shell protocol and GTK4</longdescription>
+ <use>
+ <flag name="examples">Build the example C apps</flag>
+ <flag name="smoke-tests">Test that all examples can run</flag>
+ <flag name="introspection">Build GObject Introspection data</flag>
+ <flag name="vala">Build VAPI data and Vala example. The VAPI file allows this library to be used
+ in Vala. Requires introspection.</flag>
+ </use>
+</pkgmetadata>