aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:57:17 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:57:17 +0200
commit85a2ca1a91d12b6c1c600609b687a38df7dd9498 (patch)
tree501bf7d15ab784655164bdecf09e6ce631325bcb /gui-apps
parentgui-apps/nwg-shell: drop 0.5.34 (diff)
downloadguru-85a2ca1a91d12b6c1c600609b687a38df7dd9498.tar.gz
guru-85a2ca1a91d12b6c1c600609b687a38df7dd9498.tar.bz2
guru-85a2ca1a91d12b6c1c600609b687a38df7dd9498.zip
gui-apps/nwg-shell-config: add 0.5.42
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell-config/Manifest1
-rw-r--r--gui-apps/nwg-shell-config/nwg-shell-config-0.5.42.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell-config/Manifest b/gui-apps/nwg-shell-config/Manifest
index 2eb71e47e..8c78222b8 100644
--- a/gui-apps/nwg-shell-config/Manifest
+++ b/gui-apps/nwg-shell-config/Manifest
@@ -2,3 +2,4 @@ DIST nwg-shell-config-0.5.38.tar.gz 117607 BLAKE2B d233971aa62f42b815c72977ba923
DIST nwg-shell-config-0.5.39.tar.gz 117834 BLAKE2B f842a865155e4b18260a4c75f27446ee6fcbcf5dca1911f45dfd3f48019a668ae98c7038be9d23972b182044d5fe9b51922139d5c0f9e2eea6e077a30daad88a SHA512 8c5312231ddd85c4ef7ecbf03651acd6095552822c2da3b8cc8061f067ef8e2d1990130768e63598fa5399206944fffbbcd070c69e2cee3f2b7558fdd699ebbd
DIST nwg-shell-config-0.5.40.tar.gz 117745 BLAKE2B c0fe83c86e7ffc4706fbff36a99bacbe010df682f385fdd7e89125a45076a06427844c85b68debded3a78117d4d44848bc377ccf011f8f9419b741462386dcd5 SHA512 4e7aaef64669cbe9b67ec7c9d472704db562ed290ffab2aaaf53f4ba198909758359fbe6abca258937099eec50b38f417a8f734efe92bf9879617aef6fac3c2f
DIST nwg-shell-config-0.5.41.tar.gz 117746 BLAKE2B dc7440e8da1ebd3124cf001941339daf2ba333d85f5eb0a07bbcff93c72377a4f82a9f3fed42a68dd7e4bc4e7099cff4c3c1bb11b5e0375ff69811597c78ca37 SHA512 6b38054b17ddf8220e105a56e9c10dd0fc58fd395d65eb45237fe7a5f2d4dbbd188e5672bebd0606b4eb59b613a10805b560406a0aa4bfa318ac237c9137bb99
+DIST nwg-shell-config-0.5.42.tar.gz 118692 BLAKE2B 81fb613a6528e0675ed1635e4ade3132d9266dc9c0625ee4e5f772dab103cbc702a40a7ba08ffd0082342b9631a33c190152d68da2ab5ceb3dd21ea55f20a7a8 SHA512 9f816a3236cd91d5135f214bc691066215f453eb481b088577fb38c8d9b3b9a67a5c7edf1f6689f24d4fd45722c498034ccb3a1c5ed9542cc2572e303b0e6bde
diff --git a/gui-apps/nwg-shell-config/nwg-shell-config-0.5.42.ebuild b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.42.ebuild
new file mode 100644
index 000000000..18bb5419f
--- /dev/null
+++ b/gui-apps/nwg-shell-config/nwg-shell-config-0.5.42.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="nwg-shell configuration utility"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell-config/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/nwg-shell
+ sci-geosciences/geopy
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-shell-config.desktop
+ doicon nwg-shell-config.svg
+ doicon nwg-shell-update.svg
+ doicon nwg-shell-translate.svg
+ doicon nwg-update-noupdate.svg
+ doicon nwg-update-available.svg
+ doicon nwg-update-checking.svg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}