aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-02 03:03:34 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-02 03:03:34 -0700
commit4a62b4f4a7f2580c3dee7e62b465d1237bfa0e57 (patch)
tree17eec5bac9c661d6f4e85b409c99681e7e4cafb3 /gui-apps
parentdev-python/chevron: add 0.13.1 (diff)
downloadguru-4a62b4f4a7f2580c3dee7e62b465d1237bfa0e57.tar.gz
guru-4a62b4f4a7f2580c3dee7e62b465d1237bfa0e57.tar.bz2
guru-4a62b4f4a7f2580c3dee7e62b465d1237bfa0e57.zip
gui-apps/hyprshade: new package, add 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/hyprshade/hyprshade-9999.ebuild30
-rw-r--r--gui-apps/hyprshade/metadata.xml11
2 files changed, 41 insertions, 0 deletions
diff --git a/gui-apps/hyprshade/hyprshade-9999.ebuild b/gui-apps/hyprshade/hyprshade-9999.ebuild
new file mode 100644
index 000000000..c320c9201
--- /dev/null
+++ b/gui-apps/hyprshade/hyprshade-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/loqusion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/loqusion/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Hyprland shader configuration tool"
+HOMEPAGE="https://github.com/loqusion/hyprshade"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/chevron
+ gui-wm/hyprland
+"
diff --git a/gui-apps/hyprshade/metadata.xml b/gui-apps/hyprshade/metadata.xml
new file mode 100644
index 000000000..5af97f44b
--- /dev/null
+++ b/gui-apps/hyprshade/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">loqusion/hyprshade</remote-id>
+ </upstream>
+</pkgmetadata>