aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-07 18:12:00 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-07 18:19:16 +0200
commitd0a8c98881e80d9f3fca083ee2cd8d497bdc3219 (patch)
tree8532e37e4911c4bf33b185d07959932024b49844 /gui-apps/coretime
parentgui-libs/libcsys: bump to 4.2.0_alpha; update live (diff)
downloadguru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.gz
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.bz2
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.zip
gui-apps/core*: bump to 4.2.0_alpha; update live
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/coretime')
-rw-r--r--gui-apps/coretime/Manifest1
-rw-r--r--gui-apps/coretime/coretime-4.2.0_alpha.ebuild35
-rw-r--r--gui-apps/coretime/coretime-9999.ebuild14
3 files changed, 41 insertions, 9 deletions
diff --git a/gui-apps/coretime/Manifest b/gui-apps/coretime/Manifest
index b892620ec..acdad4393 100644
--- a/gui-apps/coretime/Manifest
+++ b/gui-apps/coretime/Manifest
@@ -1,2 +1,3 @@
DIST coretime-4.0.0.tar.gz 446489 BLAKE2B 738739f568e1185d2d48500ad94ef79b0bc815c1194783187cc09ebc2d3eb127ad124730f51bcab50f90c8fd5780a192e71057fb572cc1881448613f3a49cad4 SHA512 aa3415b9a2117f3918895f55d849d781e7349d9d995f58cbc327d2ed3755ea12314166f0387dccf97aed12673d39db878925b5f97e9d1e9b5d2d5f96431cf4b6
DIST coretime-4.1.0.tar.gz 446484 BLAKE2B cd6dddc6750a71d357eecd1dbdfc0c0a2a3e79542d920012843e7056b7644b79e3e4d7a8c5f1ecfa8adba8884be22cecb2153c5d5e7eaa0d9743e16390553d59 SHA512 4620aa877dcca3ab55bfcf9a6dfad49869bb1a8862ab4501cdf6f6f6f3b99ab00451cc22e7c03d8233ffa4dc0939e1c0f4c6d75a0b2b1e75954221fb35612936
+DIST coretime-4.2.0_alpha.tar.gz 442711 BLAKE2B a72c368cf85e45900974f42a8747c053a3ab413df1a1a3f279ba0c4740daba1f905c1e99de90ebb0af04066029fc2cfdabfbd4b1575e1e3f4625789447a9b932 SHA512 f6a884e31017ce416db744ddf649b86d818d27c6ba97aa0e5cb5979e4923fedea1d1876ce7900bc075b0154e350df6a40e791a670273fae417f9675b53d95707
diff --git a/gui-apps/coretime/coretime-4.2.0_alpha.ebuild b/gui-apps/coretime/coretime-4.2.0_alpha.ebuild
new file mode 100644
index 000000000..e152ee004
--- /dev/null
+++ b/gui-apps/coretime/coretime-4.2.0_alpha.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="A time related task manager for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coretime"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"
diff --git a/gui-apps/coretime/coretime-9999.ebuild b/gui-apps/coretime/coretime-9999.ebuild
index 74d037ebc..e152ee004 100644
--- a/gui-apps/coretime/coretime-9999.ebuild
+++ b/gui-apps/coretime/coretime-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake xdg
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
DESCRIPTION="A time related task manager for C Suite"
HOMEPAGE="https://gitlab.com/cubocore/coreapps/coretime"
@@ -12,9 +14,9 @@ if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${PV}"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
fi
RESTRICT="test"
@@ -31,9 +33,3 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i 's/CSuite/X-CSuite/' *.desktop || die
-}