aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-04 12:14:00 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-04 12:14:00 +0400
commit3e6390be5c1d89b3c05ddcc5923cbfa0e7463fab (patch)
tree1f9230c75a5ff83f9c8f4ee2b2e190f34a6df62f /games-strategy
parentdev-cpp/dpp: add myself as a maintainer (diff)
downloadguru-3e6390be5c1d89b3c05ddcc5923cbfa0e7463fab.tar.gz
guru-3e6390be5c1d89b3c05ddcc5923cbfa0e7463fab.tar.bz2
guru-3e6390be5c1d89b3c05ddcc5923cbfa0e7463fab.zip
games-strategy/gigalomania: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/gigalomania/Manifest1
-rw-r--r--games-strategy/gigalomania/gigalomania-1.0.1.ebuild43
-rw-r--r--games-strategy/gigalomania/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/games-strategy/gigalomania/Manifest b/games-strategy/gigalomania/Manifest
new file mode 100644
index 000000000..1839391f1
--- /dev/null
+++ b/games-strategy/gigalomania/Manifest
@@ -0,0 +1 @@
+DIST gigalomaniasrc.zip 26975134 BLAKE2B bada94b266e30e54e4f0929673c5d9d53f25a69e84516d6f7fe5905b627a73501714b8ac307488b3ef6872b85023f67d0c862b6e58b40c25ea2091846803fd0d SHA512 255eb3d5ce566fbff42c1075c850cd2c7e2490f91bcf97954aa36ad9fb8bb787c1e817e682b0954e53c758c79ec76c431bedbf37b8197764ee40b48d09e75bcc
diff --git a/games-strategy/gigalomania/gigalomania-1.0.1.ebuild b/games-strategy/gigalomania/gigalomania-1.0.1.ebuild
new file mode 100644
index 000000000..5b0b110b0
--- /dev/null
+++ b/games-strategy/gigalomania/gigalomania-1.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Libra clone of Mega-Lo-Mania (original from ~1990), supports original resources"
+HOMEPAGE="https://gigalomania.sourceforge.net"
+SRC_URI="http://launchpad.net/$PN/trunk/$PV/+download/${PN}src.zip"
+
+S="$WORKDIR/${PN}src"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-arch/unzip
+ media-libs/libsdl2
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ DESTDIR="$D" emake install
+
+ dosym -r /opt/$PN/$PN /usr/bin/$PN
+
+ make_wrapper $PN "./$PN" /opt/$PN/
+}
+
+pkg_postinst() {
+ einfo "Supports using the graphics from Mega-Lo-Mania (from the Amiga version - should be in hard disk format, e.g., Whdload version) if you have that game."
+ einfo "The data/ folder should be copied into the main gigalomania/ folder"
+ einfo "and then rename the gfx/ folder to something else (e.g., xgfx/)."
+ einfo "It's up to you to legally obtain the game if you want this feature!"
+}
diff --git a/games-strategy/gigalomania/metadata.xml b/games-strategy/gigalomania/metadata.xml
new file mode 100644
index 000000000..00bbb6c0e
--- /dev/null
+++ b/games-strategy/gigalomania/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">gigalomania</remote-id>
+ </upstream>
+</pkgmetadata>