aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-28 01:18:34 +0200
committerJulien Roy <julien@jroy.ca>2024-05-13 18:18:20 -0400
commitd6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc (patch)
tree33de9196b9bf108bf4da7606b99327ba2c5f1af9 /games-rpg
parentdev-vcs/*: fix variable order (diff)
downloadguru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.gz
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.bz2
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.zip
games-*/*: fix variable order
I manually went through some entries for `pkgcheck scan -c VariableOrderCheck`. Misc updates: UnusedEclassesCheck RESTRICT+=" .." -> RESTRICT=".." Signed-off-by: Lucio Sauer <watermanpaint@posteo.net> Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild7
-rw-r--r--games-rpg/snoot-game/snoot-game-1.9.1.ebuild10
2 files changed, 8 insertions, 9 deletions
diff --git a/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild b/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild
index 63681e906..21d7f9fb6 100644
--- a/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild
+++ b/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild
@@ -3,18 +3,15 @@
EAPI=8
-inherit wrapper
-
DESCRIPTION="Like Diablo, isometric view, good rating, about a two hours of the gameplay"
HOMEPAGE="https://en.wikipedia.org/wiki/Sacred_(video_game)"
+SRC_URI="https://archive.org/download/${PN}.tar/${PN}.tar.xz"
-SRC_URI="https://archive.org/download/$PN.tar/$PN.tar.xz"
-
-KEYWORDS="~amd64"
S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
+KEYWORDS="~amd64"
RESTRICT="strip"
RDEPEND="
diff --git a/games-rpg/snoot-game/snoot-game-1.9.1.ebuild b/games-rpg/snoot-game/snoot-game-1.9.1.ebuild
index 92b411518..8585897b5 100644
--- a/games-rpg/snoot-game/snoot-game-1.9.1.ebuild
+++ b/games-rpg/snoot-game/snoot-game-1.9.1.ebuild
@@ -6,23 +6,25 @@ EAPI=8
PYTHON_COMPAT=( python3_{10,11,12} )
inherit python-single-r1 desktop wrapper
+MY_PV="Patch8_NewYears"
+
DESCRIPTION="Visual novel parody of Goodbye Volcano High"
-MY_PV="Patch9.1-RoastedLaika"
HOMEPAGE="https://snootgame.xyz/"
SRC_URI="https://snootgame.xyz/bin/SnootGame-${MY_PV}-linux.tar.bz2"
+S="${WORKDIR}/SnootGame-${MY_PV}-linux/"
+
LICENSE="AGPL-3 CC-BY-SA-4.0"
SLOT="0"
KEYWORDS="~amd64"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="strip"
RDEPEND="${PYTHON_DEPS} virtual/opengl"
BDEPEND="${RDEPEND}"
-S="${WORKDIR}/SnootGame-${MY_PV}-linux/"
-
QA_PREBUILT="*"
-RESTRICT+=" strip"
src_install() {
local dir=/opt/${PN}