aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-04-15 16:12:38 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-04-15 16:12:38 +0400
commit768993e09e285fbe8301d49b8e9c0c353cdafbcd (patch)
tree1bf5afd2360b3eccde020ea8ae652117af6b58e3 /games-fps
parentapp-text/lizard: fix py3.12 tests (diff)
downloadguru-768993e09e285fbe8301d49b8e9c0c353cdafbcd.tar.gz
guru-768993e09e285fbe8301d49b8e9c0c353cdafbcd.tar.bz2
guru-768993e09e285fbe8301d49b8e9c0c353cdafbcd.zip
games-fps/the-dark-mod-bin: new package, native game
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/the-dark-mod-bin/Manifest1
-rw-r--r--games-fps/the-dark-mod-bin/metadata.xml8
-rw-r--r--games-fps/the-dark-mod-bin/the-dark-mod-bin-2.12.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/games-fps/the-dark-mod-bin/Manifest b/games-fps/the-dark-mod-bin/Manifest
new file mode 100644
index 000000000..236cde46a
--- /dev/null
+++ b/games-fps/the-dark-mod-bin/Manifest
@@ -0,0 +1 @@
+DIST the-dark-mod-2.12.tar.xz 17263615692 BLAKE2B c4a7b2bbf804b46c88ded6150970989c6f6aa5e200a0cea175169f8c109b2d6bde565010bcfca200d75961f21fc90588fc347c9a2059c2a06431362e3327583c SHA512 35bba5d49a5a7dd5c612b06996a2ce43f6aa3b9e07db9fdeb42a403b1d34d825c6a6877c6690a0ae082a8a8a5e85abdcda62ccaa897a2f2c238fe492a1f456d1
diff --git a/games-fps/the-dark-mod-bin/metadata.xml b/games-fps/the-dark-mod-bin/metadata.xml
new file mode 100644
index 000000000..812e586b9
--- /dev/null
+++ b/games-fps/the-dark-mod-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-fps/the-dark-mod-bin/the-dark-mod-bin-2.12.ebuild b/games-fps/the-dark-mod-bin/the-dark-mod-bin-2.12.ebuild
new file mode 100644
index 000000000..07b2ac44a
--- /dev/null
+++ b/games-fps/the-dark-mod-bin/the-dark-mod-bin-2.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Inspired by Thief on Doom 3 libre engine (id Tech 4)"
+HOMEPAGE="
+ https://www.thedarkmod.com
+ https://en.wikipedia.org/wiki/The_Dark_Mod
+"
+SRC_URI="https://archive.org/download/the-dark-mod/the-dark-mod-$PV.tar.xz"
+
+LICENSE="
+ GPL-3
+ CC-BY-NC-ND-3.0
+"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+S="${WORKDIR}/the-dark-mod"
+
+src_install() {
+ dodir /opt
+ dodir /usr/bin/
+
+ cp -r . "$ED/opt/$PN" || die
+
+ echo "cd /opt/$PN; ./thedarkmod.x64; cd -" > "$ED/usr/bin/$PN"
+ fperms +x "/usr/bin/$PN"
+}