aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-07-25 12:53:45 +0200
committerDuje Mihanović <duje.mihanovic@skole.hr>2022-07-25 12:53:45 +0200
commit0080fcb188264b62ff506e7caed01adc80336fc8 (patch)
tree90d240406d7d6ec555ac20115698cbf590b8876a /games-fps
parentgames-fps/openspades: add -fno-strict-aliasing (diff)
downloadguru-0080fcb188264b62ff506e7caed01adc80336fc8.tar.gz
guru-0080fcb188264b62ff506e7caed01adc80336fc8.tar.bz2
guru-0080fcb188264b62ff506e7caed01adc80336fc8.zip
games-fps/assaultcube: force disable LTO
Migrating the package to GCC would probably be a better long-term solution. Closes: https://bugs.gentoo.org/859991 Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/assaultcube/assaultcube-1.3.0.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-fps/assaultcube/assaultcube-1.3.0.2.ebuild b/games-fps/assaultcube/assaultcube-1.3.0.2.ebuild
index ef8e8f81f..a1169191a 100644
--- a/games-fps/assaultcube/assaultcube-1.3.0.2.ebuild
+++ b/games-fps/assaultcube/assaultcube-1.3.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop xdg-utils
+inherit desktop xdg-utils flag-o-matic
DESCRIPTION="Free multiplayer FPS based on the Cube engine"
HOMEPAGE="https://assault.cubers.net/"
@@ -22,14 +22,15 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}"
BDEPEND="sys-devel/clang"
PATCHES=(
- "${FILESDIR}/assaultcube-1.3.0.2-respect-ldflags.patch"
- "${FILESDIR}/assaultcube-1.3.0.2-fix-checkinstall.patch" # a script which checks for required libs and certain parts of the game
+ "${FILESDIR}/${PN}-1.3.0.2-respect-ldflags.patch"
+ "${FILESDIR}/${PN}-1.3.0.2-fix-checkinstall.patch" # a script which checks for required libs and certain parts of the game
)
IUSE="debug"
src_prepare() {
default
sed -i 's|//#define PRODUCTION|#define PRODUCTION|' "${S}/source/src/cube.h"
+ filter-lto
}
src_compile() {