aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2024-03-11 23:02:03 +0100
committerOliver Freyermuth <o.freyermuth@googlemail.com>2024-03-11 23:02:03 +0100
commitb354ab4d23a555eb72854363da94707db8c56105 (patch)
tree3316557dae66f29c4e4c0d589504a3280dc916b3 /games-arcade
parentapp-misc/vocabsieve: add multimedia USE for PyQt5 (diff)
downloadguru-b354ab4d23a555eb72854363da94707db8c56105.tar.gz
guru-b354ab4d23a555eb72854363da94707db8c56105.tar.bz2
guru-b354ab4d23a555eb72854363da94707db8c56105.zip
games-arcade/taisei: add 1.4.1
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/taisei/Manifest1
-rw-r--r--games-arcade/taisei/taisei-1.4.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/taisei/Manifest b/games-arcade/taisei/Manifest
index 8859e2515..ce0718fe9 100644
--- a/games-arcade/taisei/Manifest
+++ b/games-arcade/taisei/Manifest
@@ -1,2 +1,3 @@
+DIST taisei-1.4.1.tar.xz 219550456 BLAKE2B 640b4e53b4ee4784173a8ba0ea435a75aa547a788e549f56c3dff99f9a36997a3c7c73d857fc86bf7aa10d6c22f3bf826991d3a61147e2ec24771fb96c987ed6 SHA512 7c11ed1c7a7898ca4f43854224c8e55305fcef8312f0d32b488c85fbf16cceaa84fd52948bb81e311095b93254d95ea7eaa8f85c42bbbe54cf81d2702242cb2b
DIST taisei-1.4.tar.xz 219573588 BLAKE2B c5a3300f3274ccc13e1beef9eb673affc223d761dfb632d9b067bc7cf401c3ed0422a78e0dba5334ab003044dae2cb24efb892edc955ee417ebc6c0477617314 SHA512 5715fd7dca868a3987941f24e26fb8ddc507ca5cb4e3c6a2b9c021bc0742d164e6ff2410f7b8de85907baa90f2c4b34925ac1196b163474047bee60141befb86
DIST taisei-v1.3.2.tar.xz 70481856 BLAKE2B 608b5db6f17e2693539ce0742a1812633e91e901b3935b9e54f91514827642334f6cb6f0217aff713f1ff9dd01d971ae895ac8c98b0360f254b52d3e49bfae61 SHA512 9304c082106dfa1ffcf6c8fb7333e64755b1246ef50b9f49d3e64d167eb15575ac667ca658b1d7e247582e164e703e5817384556dd633f5516670d975817717d
diff --git a/games-arcade/taisei/taisei-1.4.1.ebuild b/games-arcade/taisei/taisei-1.4.1.ebuild
new file mode 100644
index 000000000..3d5d508fa
--- /dev/null
+++ b/games-arcade/taisei/taisei-1.4.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+
+inherit meson python-any-r1 xdg
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/taisei-project/taisei.git"
+else
+ # Auto-generated tarballs lacks submodules, all of which are taisei subrepos
+ SRC_URI="https://github.com/taisei-project/taisei/releases/download/v${PV}/taisei-${PV}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Clone of the Touhou series, written in C using SDL/OpenGL/OpenAL."
+HOMEPAGE="https://taisei-project.org/"
+LICENSE="MIT CC-BY-4.0 CC0-1.0 public-domain"
+SLOT="0"
+
+IUSE="doc lto zip"
+
+RDEPEND="
+ media-libs/freetype:2
+ media-libs/opusfile
+ >=media-libs/libpng-1.5
+ media-libs/libsdl2
+ media-libs/libwebp
+ media-libs/opusfile
+ app-arch/zstd
+ sys-libs/zlib
+ dev-libs/openssl:=
+ zip? ( dev-libs/libzip )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/cglm-0.7.8
+"
+BDEPEND="
+ dev-build/meson
+ $(python_gen_any_dep '
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ doc? ( dev-python/docutils )"
+
+python_check_deps() {
+ python_has_version "dev-python/zstandard[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # Path patching needed also without USE=doc (COPYING etc.)
+ sed -i "s/doc_path = join.*/doc_path = join_paths(datadir, \'doc\', \'${PF}\')/" \
+ meson.build || die "Failed changing doc_path"
+
+ # Remove blobs
+ rm external/basis_universal/OpenCL/lib/*.lib \
+ external/basis_universal/webgl_videotest/basis.wasm \
+ external/basis_universal/webgl/transcoder/build/basis_transcoder.wasm \
+ external/basis_universal/webgl/encoder/build/basis_encoder.wasm \
+ || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc docs)
+ $(meson_use lto b_lto)
+ $(meson_feature zip vfs_zip)
+ -Dstrip=false
+ -Duse_libcrypto=enabled
+ )
+ meson_src_configure
+}