aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2024-08-05 19:55:00 +0200
committerMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2024-08-05 19:59:06 +0200
commit1405f9bc8d8c3725a06e5c7aaca5ac248b248531 (patch)
tree19cd39436365b6a772de3ddda2220c3eb600b614 /dev-util
parentsci-physics/openmodelica: Install OMEdit icon (diff)
downloadguru-1405f9bc8d8c3725a06e5c7aaca5ac248b248531.tar.gz
guru-1405f9bc8d8c3725a06e5c7aaca5ac248b248531.tar.bz2
guru-1405f9bc8d8c3725a06e5c7aaca5ac248b248531.zip
dev-util/shellspec: new package, add 0.28.1, 9999
Signed-off-by: Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shellspec/Manifest1
-rw-r--r--dev-util/shellspec/metadata.xml46
-rw-r--r--dev-util/shellspec/shellspec-0.28.1.ebuild63
-rw-r--r--dev-util/shellspec/shellspec-9999.ebuild63
4 files changed, 173 insertions, 0 deletions
diff --git a/dev-util/shellspec/Manifest b/dev-util/shellspec/Manifest
new file mode 100644
index 0000000000..1f595a6b81
--- /dev/null
+++ b/dev-util/shellspec/Manifest
@@ -0,0 +1 @@
+DIST shellspec-0.28.1.tar.gz 440575 BLAKE2B 08d59f1585d155cd0a7d45b939f7172b3a3f58350e32993f2e0b88307ed3d214dddeff7468c322b6ff9f51223d5b681a6fc85bfd24c46d2224421d7d3e6c43ef SHA512 a3d1f582a3c76ef240ab9bd0ce3b8433d7ced766b6fa03ed724100917271c2c0ee04909cdc7ea2f92267dc11fdd890d52a4edcc2957c16dbbd331a718e5c564f
diff --git a/dev-util/shellspec/metadata.xml b/dev-util/shellspec/metadata.xml
new file mode 100644
index 0000000000..dcf01adc35
--- /dev/null
+++ b/dev-util/shellspec/metadata.xml
@@ -0,0 +1,46 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>beatussum@protonmail.com</email>
+ <name>Mattéo Rossillol‑‑Laruelle</name>
+ </maintainer>
+ <longdescription>
+ <pkg>dev-util/shellspec</pkg> is a full-featured BDD unit
+ testing framework for <pkg>app-shells/dash</pkg>,
+ <pkg>app-shells/bash</pkg>, <pkg>app-shells/ksh</pkg>,
+ <pkg>app-shells/zsh</pkg> and all POSIX shells that provides
+ first-class features such as code coverage, mocking,
+ parameterized test, parallel execution and more. It was
+ developed as a dev/test tool for cross-platform shell scripts
+ and shell script libraries. <pkg>dev-util/shellspec</pkg> is a
+ new modern testing framework released in 2019, but it's already
+ stable enough. With lots of practical CLI features and simple
+ yet powerful syntax, it provides you with a fun shell script
+ test environment.
+ </longdescription>
+ <longdescription lang="fr">
+ <pkg>dev-util/shellspec</pkg> est une infrastructure logicielle
+ de tests unitaires BDD pour <pkg>app-shells/dash</pkg>,
+ <pkg>app-shells/bash</pkg>, <pkg>app-shells/ksh</pkg>,
+ <pkg>app-shells/zsh</pkg> et tous les shells POSIX qui fournit
+ des fonctionnalités de premier ordre telles que la couverture de
+ code, le mocking, test paramétré, l'exécution parallèle et plus
+ encore. Elle a été développée en tant qu'outil de
+ développement/test pour les scripts shell multiplateformes et
+ les bibliothèques de scripts shell.
+ <pkg>dev-util/shellspec</pkg> est une nouvelle infrastructure
+ logicielle de test moderne publié en 2019, mais elle est déjà
+ assez stable. Avec de nombreuses fonctionnalités CLI pratiques
+ et une syntaxe simple syntaxe simple mais puissante, elle vous
+ fournit un environnement de test de script shell.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <name>ShellSpec</name>
+ </maintainer>
+ <changelog>https://github.com/shellspec/shellspec/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/shellspec/shellspec/issues/</bugs-to>
+ <remote-id type="github">shellspec/shellspec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/shellspec/shellspec-0.28.1.ebuild b/dev-util/shellspec/shellspec-0.28.1.ebuild
new file mode 100644
index 0000000000..aeeb16f9ff
--- /dev/null
+++ b/dev-util/shellspec/shellspec-0.28.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A full-featured BDD unit testing framework for all POSIX shells"
+HOMEPAGE="https://shellspec.info/"
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/shellspec/shellspec.git"
+else
+ SRC_URI="https://github.com/shellspec/shellspec/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="doc examples test"
+RESTRICT="binchecks strip !test? ( test )"
+
+DEPEND="
+ || (
+ >=app-shells/bash-2.03
+ >=app-shells/dash-0.5.4
+ app-shells/ksh
+ app-shells/loksh
+ >=app-shells/mksh-28r
+ >=app-shells/posh-0.3.14
+ >=app-shells/yash-2.29
+ >=app-shells/zsh-3.1.9
+ >=sys-apps/busybox-1.20.0
+ )
+"
+
+BDEPEND="test? ( ${DEPEND} )"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ CHANGELOG.md
+ CONTRIBUTING.md
+ README.md
+)
+
+src_prepare() {
+ default
+ sed -i "s/LICENSE//g" Makefile || die
+}
+
+src_compile() { :; }
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ einstalldocs
+
+ use doc && dodoc -r docs
+ use examples && dodoc -r examples
+
+ emake PREFIX="${ED}/usr" install
+}
diff --git a/dev-util/shellspec/shellspec-9999.ebuild b/dev-util/shellspec/shellspec-9999.ebuild
new file mode 100644
index 0000000000..aeeb16f9ff
--- /dev/null
+++ b/dev-util/shellspec/shellspec-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A full-featured BDD unit testing framework for all POSIX shells"
+HOMEPAGE="https://shellspec.info/"
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/shellspec/shellspec.git"
+else
+ SRC_URI="https://github.com/shellspec/shellspec/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="doc examples test"
+RESTRICT="binchecks strip !test? ( test )"
+
+DEPEND="
+ || (
+ >=app-shells/bash-2.03
+ >=app-shells/dash-0.5.4
+ app-shells/ksh
+ app-shells/loksh
+ >=app-shells/mksh-28r
+ >=app-shells/posh-0.3.14
+ >=app-shells/yash-2.29
+ >=app-shells/zsh-3.1.9
+ >=sys-apps/busybox-1.20.0
+ )
+"
+
+BDEPEND="test? ( ${DEPEND} )"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ CHANGELOG.md
+ CONTRIBUTING.md
+ README.md
+)
+
+src_prepare() {
+ default
+ sed -i "s/LICENSE//g" Makefile || die
+}
+
+src_compile() { :; }
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ einstalldocs
+
+ use doc && dodoc -r docs
+ use examples && dodoc -r examples
+
+ emake PREFIX="${ED}/usr" install
+}