aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-05-19 22:59:43 +0200
committerMaciej Barć <xgqt@riseup.net>2021-05-19 23:02:07 +0200
commit6b418b7bfa07ccaf65c01ba252407796099d331e (patch)
treeb92d5d440eeaa4624ca86937600f1d53f7af3682 /dev-scheme
parentsci-libs/dart: fix typo (diff)
downloadguru-6b418b7bfa07ccaf65c01ba252407796099d331e.tar.gz
guru-6b418b7bfa07ccaf65c01ba252407796099d331e.tar.bz2
guru-6b418b7bfa07ccaf65c01ba252407796099d331e.zip
dev-scheme/owl-lisp: add version 0.2 and live
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/owl-lisp/Manifest1
-rw-r--r--dev-scheme/owl-lisp/metadata.xml18
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.ebuild43
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-9999.ebuild43
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-scheme/owl-lisp/Manifest b/dev-scheme/owl-lisp/Manifest
new file mode 100644
index 000000000..0a54360a4
--- /dev/null
+++ b/dev-scheme/owl-lisp/Manifest
@@ -0,0 +1 @@
+DIST owl-v0.2.tar.gz 515574 BLAKE2B 054a06d33554cc31f5e1c756bf3ff5ea4fb5cec220048fb939aa9dcd19c586cef54ae8ddc80e1ee8befedfa2e42fc1bf9ea4bcfe37e6743154ff678346444e87 SHA512 f0dc4badc84be1ebd1ad8f6a84c8fc292449b0f66a9416f202f9010e89aa2971c6470599173db67bf3db3e4b6a61d777ee369eda76fa7c42114748e8fe48b7b2
diff --git a/dev-scheme/owl-lisp/metadata.xml b/dev-scheme/owl-lisp/metadata.xml
new file mode 100644
index 000000000..573127cc4
--- /dev/null
+++ b/dev-scheme/owl-lisp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Owl Lisp is a simple programming language. The main motivation for
+ writing it was to get a portable system for writing standalone
+ programs in a subjectively pleasant dialect of LISP, which in this
+ case means a minimal core language and runtime, purely functional
+ operation and support for asynchronous evaluation.
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">owl-lisp/owl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
new file mode 100644
index 000000000..0897bd636
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v0.2/owl-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ # warning: jobserver unavailable
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+
+ exeinto /usr/bin
+ doexe ./bin/ol
+ newexe ./bin/vm ovm
+
+ doman ./doc/ol.1
+ doman ./doc/ovm.1
+}
diff --git a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
new file mode 100644
index 000000000..0897bd636
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v0.2/owl-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ # warning: jobserver unavailable
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+
+ exeinto /usr/bin
+ doexe ./bin/ol
+ newexe ./bin/vm ovm
+
+ doman ./doc/ol.1
+ doman ./doc/ovm.1
+}