aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-10-02 17:45:30 +0200
committerDavid Roman <davidroman96@gmail.com>2023-10-02 17:45:30 +0200
commitf864945f1fbfa3da4182e66d15da9cc64ad9de6b (patch)
tree6ee92c0b5b03a3c78cef0ccdbed67af700b84d8f /dev-python
parentdev-python/python-telegram-bot: add 20.5 (diff)
downloadguru-f864945f1fbfa3da4182e66d15da9cc64ad9de6b.tar.gz
guru-f864945f1fbfa3da4182e66d15da9cc64ad9de6b.tar.bz2
guru-f864945f1fbfa3da4182e66d15da9cc64ad9de6b.zip
dev-python/python-telegram-bot: drop 13.14, 20.2-r1
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-telegram-bot/Manifest2
-rw-r--r--dev-python/python-telegram-bot/python-telegram-bot-13.14.ebuild68
-rw-r--r--dev-python/python-telegram-bot/python-telegram-bot-20.2-r1.ebuild57
3 files changed, 0 insertions, 127 deletions
diff --git a/dev-python/python-telegram-bot/Manifest b/dev-python/python-telegram-bot/Manifest
index 1bdffae65..4b5bd4db2 100644
--- a/dev-python/python-telegram-bot/Manifest
+++ b/dev-python/python-telegram-bot/Manifest
@@ -1,4 +1,2 @@
-DIST python-telegram-bot-13.14.tar.gz 2282098 BLAKE2B 549c87737585f3b2b4bae9f9430fcf8dbaf4f9048013f623b5ef910534a0c70792e36eedffa707b4ff68d6de53c69d4befe64618fc8944c35c3efe680294c4a9 SHA512 859d9852feaaf147b608c1ef4e5f388c345f7efcd699a828d690b110fb499cb9391a51bafe8e0b533d106dccf038a4c845fa13c0dab12bb7792dffe5d059af27
-DIST python-telegram-bot-20.2.tar.gz 1940084 BLAKE2B a575f7ea616e29c32f3773adc66153ddbe4563420697d5eb2dcb1ad7df72d5ea348b0900552d65a91fdfe9c4d65c4fc1d43e9e5e7bb18d5943ae0d329878a6a0 SHA512 1d25a7c0c8b97c3292af364f1c9f94289de340d19587f2d43817f36bd89c3862fe6c1cf58b68dcdfa5aca6a94acb8da99bb49a9f4ad76e3a61b3b59810dae6e5
DIST python-telegram-bot-20.3.tar.gz 1957466 BLAKE2B 47e68846bb6c092648aa2bcd53289f7ac78d7335a8f84fd6a1c6440ee8b38c150f2e2df56f537e0de9e01af3c98a49fd0a8d8771c15ebd9be1658b0ee17a355b SHA512 6594eb991a14acdd247505b904ca2bd5022ef8abe4b45b57218508fa53de765a6a9e05c78997723a8385b45a0950e87dc102264ed3338eed9d569d1eb596e1f9
DIST python-telegram-bot-20.5.tar.gz 1950471 BLAKE2B b25440dd78d3a72242d371ec661027d2fea7c174a20a1c7482f0d1cab07aa6e5ffa886bb944c217e177732aabec676e5ea6003431a5e893a7171bb36642e3c53 SHA512 65f8d3de73bffcf56dd986091c34fa8f9cb60b4b8bbfc2b1c5c7392cf3a6314192a97013a2299a4d02977fd4f6ae73c487acc7a839b700d7304b02c0f5680671
diff --git a/dev-python/python-telegram-bot/python-telegram-bot-13.14.ebuild b/dev-python/python-telegram-bot/python-telegram-bot-13.14.ebuild
deleted file mode 100644
index 916c66994..000000000
--- a/dev-python/python-telegram-bot/python-telegram-bot-13.14.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper of telegram bots API"
-HOMEPAGE="https://python-telegram-bot.org https://github.com/python-telegram-bot/python-telegram-bot"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/python-telegram-bot/python-telegram-bot"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# This error is really strange
-# UserWarning: python-telegram-bot is using upstream urllib3. This is allowed but not supported by python-telegram-bot maintainers.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/APScheduler[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
-
-python_prepare_all() {
- # do not make a test flaky report
- sed -i -e '/addopts/d' setup.cfg || die
-
- sed -i 's/from telegram.vendor.ptb_urllib3 //g' tests/test_*.py
- sed -i 's/telegram.vendor.ptb_urllib3.urllib3/urllib3/g' tests/test_*.py
-
- # Remove tests files that require network access
- rm tests/test_{animation,audio,bot,commandhandler,constants,conversationhandler}.py || die
- rm tests/test_{dispatcher,document,forcereply,inlinekeyboardmarkup,inputmedia}.py || die
- rm tests/test_{invoice,jobqueue,official,parsemode,persistence,photo,sticker,updater}.py || die
- rm tests/test_replykeyboard{markup,remove}.py || die
- rm tests/test_{video,videonote,voice}.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/python-telegram-bot/python-telegram-bot-20.2-r1.ebuild b/dev-python/python-telegram-bot/python-telegram-bot-20.2-r1.ebuild
deleted file mode 100644
index 9b383fdb3..000000000
--- a/dev-python/python-telegram-bot/python-telegram-bot-20.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python wrapper of telegram bots API"
-HOMEPAGE="https://docs.python-telegram-bot.org https://github.com/python-telegram-bot/python-telegram-bot"
-SRC_URI="https://github.com/python-telegram-bot/python-telegram-bot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=dev-python/cachetools-5.3.0[${PYTHON_USEDEP}]
- >=dev-python/cryptography-39.0.1[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.23.3[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-no-internet-tests.patch"
-)
-
-S="${WORKDIR}/${PN}-${PV}"
-
-distutils_enable_tests pytest
-
-# Run only the tests that don't require a connection
-python_test() {
- epytest -m no_req
-}
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- optfeature_header "Optional package dependencies:"
- optfeature "using telegram.ext.JobQueue" dev-python/APScheduler
-}