aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-29 14:27:34 -0500
committerJulien Roy <julien@jroy.ca>2023-01-29 14:27:34 -0500
commit7a696ec76166a20ece4ca8a14283b24f2c833624 (patch)
tree99f66c38e7f7b6099eee5bb01b3cb9990f5516f5 /dev-python
parentdev-python/devtools: add 0.10.0, drop 0.6.1 (diff)
downloadguru-7a696ec76166a20ece4ca8a14283b24f2c833624.tar.gz
guru-7a696ec76166a20ece4ca8a14283b24f2c833624.tar.bz2
guru-7a696ec76166a20ece4ca8a14283b24f2c833624.zip
dev-python/curio: add 1.6, drop 1.5
Closes: https://bugs.gentoo.org/848165 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/curio/Manifest2
-rw-r--r--dev-python/curio/curio-1.5.ebuild50
-rw-r--r--dev-python/curio/curio-1.6.ebuild27
-rw-r--r--dev-python/curio/metadata.xml22
4 files changed, 42 insertions, 59 deletions
diff --git a/dev-python/curio/Manifest b/dev-python/curio/Manifest
index 6e217e529..69cf93cf6 100644
--- a/dev-python/curio/Manifest
+++ b/dev-python/curio/Manifest
@@ -1 +1 @@
-DIST curio-1.5.tar.gz 234920 BLAKE2B 26e3c0de872d77478f433990f88f9ac35f9615621aadfcc7b8d766488ffe390fd4698854640792bda4e649fc0d1224fa7cb5bf89777268fee4349500a5365547 SHA512 8c78d866b949da862ddb29d6a8db6881d00dedb33637529d02d4e3010de0e1ecd15e74f52c011828738ac7d54e5f04425c8ffb43abaf1e77c21d28d874ff711b
+DIST curio-1.6.tar.gz 235660 BLAKE2B b09f0c5cf62a99efefd95727f5547cf4f02a8b921b52f21051acb206098886fec63123772b826efa1c2842291cbcf4225324e5d7a85b103caacf94035be741ec SHA512 480824a50055d170cc01e2ab28dc1b276df9ab8dfbd50f3c70fe6e3fe2a745b636a4717f7886463a1ed38d6fc357098239e1718e00c8f983369b72f4e5d20f17
diff --git a/dev-python/curio/curio-1.5.ebuild b/dev-python/curio/curio-1.5.ebuild
deleted file mode 100644
index f68f7b80d..000000000
--- a/dev-python/curio/curio-1.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Curio is a coroutine-based library for concurrent systems programming"
-HOMEPAGE="
- https://github.com/dabeaz/curio
- https://pypi.org/project/curio/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-IUSE="examples"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-DEPEND="test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs --no-autodoc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # requires internet connection
- sed -i -e 's:test_ssl_outgoing:_&:' \
- tests/test_network.py || die
-
- # AttributeError: module 'asyncio' has no attribute 'run'
- sed -i -e 's:test_uqueue_asyncio_consumer:_&:' \
- tests/test_queue.py || die
- sed -i -e 's:test_uevent_get_asyncio_set:_&:' \
- -e 's:test_uevent_get_asyncio_wait:_&:' \
- -e 's:test_universal_error:_&:' \
- -e 's:test_universal_value:_&:' \
- tests/test_sync.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/curio/curio-1.6.ebuild b/dev-python/curio/curio-1.6.ebuild
new file mode 100644
index 000000000..8482fd334
--- /dev/null
+++ b/dev-python/curio/curio-1.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Curio is a coroutine-based library for concurrent systems programming"
+HOMEPAGE="
+ https://github.com/dabeaz/curio
+ https://pypi.org/project/curio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="examples"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
diff --git a/dev-python/curio/metadata.xml b/dev-python/curio/metadata.xml
index 6a58b1a32..0814446ba 100644
--- a/dev-python/curio/metadata.xml
+++ b/dev-python/curio/metadata.xml
@@ -1,16 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
Curio is a coroutine-based library for concurrent Python systems programming. It provides standard programming abstractions such as as tasks, sockets, files, locks, and queues. It works on Unix and Windows. You'll find it to be familiar, small, fast, and fun
Core Features
Curio supports standard synchronization primitives (events, locks, recursive locks, semaphores, and condition variables), queues, subprocesses, as well as running tasks in threads and processes. The task model fully supports cancellation, task groups, timeouts, monitoring, and other features critical to writing reliable code.
- </longdescription>
- <upstream>
- <remote-id type="github">dabeaz/curio</remote-id>
- <remote-id type="pypi">curio</remote-id>
- </upstream>
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <name>David Beazley</name>
+ <email>dave@dabeaz.com</email>
+ </maintainer>
+ <remote-id type="github">dabeaz/curio</remote-id>
+ <remote-id type="pypi">curio</remote-id>
+ <bugs-to>https://github.com/dabeaz/curio/issues</bugs-to>
+ <changelog>https://github.com/dabeaz/curio/blob/master/CHANGES</changelog>
+ <doc>https://curio.readthedocs.io/</doc>
+ </upstream>
</pkgmetadata>