aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-07-12 00:18:21 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-07-12 00:19:17 +0500
commit106733ded772325190dcf82effe8eb811edeb15e (patch)
treeeaba399b9ab89120b5f6859ddfe82410d7803f7c /dev-python
parentdev-python/baron: update EAPI 7 -> 8 (diff)
downloadguru-106733ded772325190dcf82effe8eb811edeb15e.tar.gz
guru-106733ded772325190dcf82effe8eb811edeb15e.tar.bz2
guru-106733ded772325190dcf82effe8eb811edeb15e.zip
dev-python/asyncpg: add 0.26.0, drop 0.23.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/asyncpg/Manifest2
-rw-r--r--dev-python/asyncpg/asyncpg-0.26.0.ebuild (renamed from dev-python/asyncpg/asyncpg-0.23.0.ebuild)27
2 files changed, 17 insertions, 12 deletions
diff --git a/dev-python/asyncpg/Manifest b/dev-python/asyncpg/Manifest
index 0843f7e44..4ccb5036a 100644
--- a/dev-python/asyncpg/Manifest
+++ b/dev-python/asyncpg/Manifest
@@ -1,2 +1,2 @@
-DIST asyncpg-0.23.0.tar.gz 775098 BLAKE2B 8afcbf1a39de87b29089fec871bae36f4bdbb38114d08b9badf7b0e2b2d19b074efe5a2ea90b611bb1d32b3b9365124cc17bba10874d2d73a267fc13028aff6a SHA512 bfb47b9d7faac4c7a0d49164c062b68c3fa3a9abac822b75b975bf41c45f6c6be25c4537140e75e1323fe1615bb03353d5ba50ef13d64c5a646293629a643b39
DIST asyncpg-0.25.0.tar.gz 804292 BLAKE2B 55e679716fe6dab82be9142f1abaa0e47671341b91f4fd182ad564e41a61dbc91990f767e6b0e7d0d00658d530075493d67f284272239c92d3015016ec0dfb2b SHA512 7afa5ae42c0d5cab93bb1c3266bad11ce2e7c271d7ffd2c5d92e373fd8e06be89e4b18e8fd3ffd7e750e913944630f1ae6c947e20faa63f99ded7d867ad6cd80
+DIST asyncpg-0.26.0.tar.gz 809997 BLAKE2B 360dfadcd729ade63c156e3a16def7f652dbc4d0c76189ac88e01fa814f9a3ab4f1bd2852658a93e22a8e275fb1a4e69df2e3c30f457110291f0641ac6d12d8d SHA512 ef92316fd430a1819aa8170abd67ecfc1cf29c42cb6dc06cf5047cdd71d4abf441c8b86bacafaaa8c0c0fd7c66daa275e9ed68b00e5166bb27929f25cab1dcbd
diff --git a/dev-python/asyncpg/asyncpg-0.23.0.ebuild b/dev-python/asyncpg/asyncpg-0.26.0.ebuild
index 2441b299d..b2bba5cf8 100644
--- a/dev-python/asyncpg/asyncpg-0.23.0.ebuild
+++ b/dev-python/asyncpg/asyncpg-0.26.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} ) # doesn't build with pypy3
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
-DESCRIPTION="A fast PostgreSQL Database Client Library for Python/asyncio."
+DESCRIPTION="A fast PostgreSQL Database Client Library for Python/asyncio"
HOMEPAGE="https://github.com/MagicStack/asyncpg"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
@@ -15,12 +15,17 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# ModuleNotFoundError: No module named 'asyncpg.protocol.protocol'
-# for some reason, still doesn't work if package is already installed
-# or with distutils_install_for_testing function
-RESTRICT="test"
-
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+
distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio dev-python/sphinx_rtd_theme
+
+python_compile() {
+ if use test; then
+ esetup.py build_ext --force --inplace
+ rm -r build || die
+ fi
+
+ distutils-r1_python_compile
+}