aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2022-09-17 15:08:04 +0200
committerDavid Roman <davidroman96@gmail.com>2022-09-17 15:08:04 +0200
commit53f07ce7389a80fdb569ecbed6b9309e97cadd8a (patch)
tree0cadf9032791daee99f5d2ab1c7a347735f20962 /dev-python/tweepy
parentdev-python/guidata: add 2.3.0, drop 2.1.1 (diff)
downloadguru-53f07ce7389a80fdb569ecbed6b9309e97cadd8a.tar.gz
guru-53f07ce7389a80fdb569ecbed6b9309e97cadd8a.tar.bz2
guru-53f07ce7389a80fdb569ecbed6b9309e97cadd8a.zip
dev-python/tweepy: verbump to 4.10.1
Closes: https://bugs.gentoo.org/849623 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/Manifest3
-rw-r--r--dev-python/tweepy/tweepy-3.10.0.ebuild31
-rw-r--r--dev-python/tweepy/tweepy-4.10.1.ebuild (renamed from dev-python/tweepy/tweepy-4.10.0.ebuild)2
3 files changed, 3 insertions, 33 deletions
diff --git a/dev-python/tweepy/Manifest b/dev-python/tweepy/Manifest
index 3daa794a2..173458adf 100644
--- a/dev-python/tweepy/Manifest
+++ b/dev-python/tweepy/Manifest
@@ -1,2 +1 @@
-DIST tweepy-3.10.0.tar.gz 459678 BLAKE2B 8ed612e9a0ad0892110658c94bcf70ec3da4219c74fe9e4600bebd8ce16a81ef03461924aa9d170ccf3ae9127cfa0bc35a7d36a4b379b44ab5557eba8d30972c SHA512 2a40875c5612902e4ff69e6fdf73e9fa10b93a80bf4160b16e44e2dae058a90f86569b3a4bcb67a7acdf5c9c3119ce7ca35a3ae64e393181b78fde10dfd975b5
-DIST tweepy-4.10.0.tar.gz 5898258 BLAKE2B 862eb1b8c804171204ef636be3844e92c8a0ded8dbb3c9d3e9aa7c7379617f5e711385ac5df2849f48505f9ab74acd21b9239694033f9d1f2232c45e8e7f0815 SHA512 b84ff3ba795f0da775970cdf62cb8b614dcf287149398b9457be7a6049b8591369d5b181ec8bcd7bf4c4dd5994040c0eaa6e73179cae550bc56ee8b32324fd71
+DIST tweepy-4.10.1.tar.gz 5898710 BLAKE2B da6e411f9021a6de65b4ef083784fc07b086ceefa9e86b35ddbc7843902bfacdca080f7d66a9a1567e8c566731b1ba2da6d7f090c7c7555122da947b1293254d SHA512 bcc22f871cdc016004707d00ef562dd8c75d1cd684d1077d7336970ce76565d698e46cbf6477be70d72f14fa5f6c4a93a37408c5b8993d115108419b96a60b53
diff --git a/dev-python/tweepy/tweepy-3.10.0.ebuild b/dev-python/tweepy/tweepy-3.10.0.ebuild
deleted file mode 100644
index 33863287a..000000000
--- a/dev-python/tweepy/tweepy-3.10.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_8 )
-
-inherit distutils-r1
-
-DESCRIPTION="An easy-to-use Python library for accessing the Twitter API."
-HOMEPAGE="https://www.tweepy.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP},socks5]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/vcrpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests nose
diff --git a/dev-python/tweepy/tweepy-4.10.0.ebuild b/dev-python/tweepy/tweepy-4.10.1.ebuild
index ffcb1bdcc..68c669028 100644
--- a/dev-python/tweepy/tweepy-4.10.0.ebuild
+++ b/dev-python/tweepy/tweepy-4.10.1.ebuild
@@ -23,6 +23,8 @@ RDEPEND="
DEPEND="
${RDEPEND}
test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/async-lru[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/vcrpy[${PYTHON_USEDEP}]
)