aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-26 19:25:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-26 20:37:08 +0200
commitf814ef2c9cbd119c27a2cf3889c84612bc7765d2 (patch)
treed1637491efd6bf36e5bfcc8dce18f4ddb54628fb /dev-python/daiquiri
parentdev-python/python-json-logger: initial import (diff)
downloadguru-f814ef2c9cbd119c27a2cf3889c84612bc7765d2.tar.gz
guru-f814ef2c9cbd119c27a2cf3889c84612bc7765d2.tar.bz2
guru-f814ef2c9cbd119c27a2cf3889c84612bc7765d2.zip
dev-python/daiquiri: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/daiquiri')
-rw-r--r--dev-python/daiquiri/Manifest1
-rw-r--r--dev-python/daiquiri/daiquiri-3.0.1.ebuild29
-rw-r--r--dev-python/daiquiri/files/testrepository-0.0.20-test-backport.patch62
-rw-r--r--dev-python/daiquiri/files/testrepository-0.0.20-test-backport1.patch16
-rw-r--r--dev-python/daiquiri/files/testrepository-0.0.20-test-backport2.patch49
-rw-r--r--dev-python/daiquiri/metadata.xml15
6 files changed, 172 insertions, 0 deletions
diff --git a/dev-python/daiquiri/Manifest b/dev-python/daiquiri/Manifest
new file mode 100644
index 000000000..6a12a3d94
--- /dev/null
+++ b/dev-python/daiquiri/Manifest
@@ -0,0 +1 @@
+DIST daiquiri-3.0.1.tar.gz 17948 BLAKE2B 1865d1e6b7ad0a1c9b8390992255726a3383034fd631cd217cb2ac820106efaeced3e44168f14d4b8c851e0c17a5d980aeb28a3d3ea3399701af2ea1c248b9c0 SHA512 4c786a744a8ed89147bb77c8825d8733ca88bf1d1877058c87257c92a7ae3b343a0820e9d83f4ac8a2a1b9b74d33f72bb5b306703b3bd57b51cf7931041c5d6c
diff --git a/dev-python/daiquiri/daiquiri-3.0.1.ebuild b/dev-python/daiquiri/daiquiri-3.0.1.ebuild
new file mode 100644
index 000000000..f2e683390
--- /dev/null
+++ b/dev-python/daiquiri/daiquiri-3.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to easily setup basic logging functionality"
+HOMEPAGE="
+ https://pypi.org/project/daiquiri
+ https://github.com/jd/daiquiri
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/python-json-logger[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/daiquiri/files/testrepository-0.0.20-test-backport.patch b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport.patch
new file mode 100644
index 000000000..d7ab87c06
--- /dev/null
+++ b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport.patch
@@ -0,0 +1,62 @@
+From 8f8ab15fafdad6db850c84772323b32375b09285 Mon Sep 17 00:00:00 2001
+From: Robert Collins <robertc@robertcollins.net>
+Date: Tue, 10 Mar 2015 15:21:49 +1300
+Subject: [PATCH] Fixup tests with latest testtools.
+
+Testtools has started chunking exceptions (which is perhaps good,
+perhaps bad) - but we shouldn't depend on the exact behaviour in it
+for our tests.
+--- a/NEWS
++++ b/NEWS
+@@ -5,6 +5,12 @@ testrepository release notes
+ NEXT (In development)
+ +++++++++++++++++++++
+
++CHANGES
++-------
++
++* Isolate the testrepository test suite from the chunking (or otherwise)
++ behaviour of testtools' exception handlers. (Robert Collins)
++
+ 0.0.20
+ ++++++
+
+--- a/testrepository/tests/test_repository.py
++++ b/testrepository/tests/test_repository.py
+@@ -28,6 +28,7 @@
+ from testresources import TestResource
+ from testtools import (
+ clone_test_with_new_id,
++ content,
+ PlaceHolder,
+ )
+ import testtools
+@@ -103,19 +104,24 @@ class Case(ResourcedTestCase):
+ def passing(self):
+ pass
+
+- def failing(self):
+- self.fail("oops")
+-
+ def unexpected_success(self):
+ self.expectFailure("unexpected success", self.assertTrue, True)
+
+
++class FailingCase:
++
++ def run(self, result):
++ result.startTest(self)
++ result.addError(
++ self, None, details={'traceback': content.text_content("")})
++ result.stopTest(self)
++
+ def make_test(id, should_pass):
+ """Make a test."""
+ if should_pass:
+ case = Case("passing")
+ else:
+- case = Case("failing")
++ case = FailingCase()
+ return clone_test_with_new_id(case, id)
+
+
diff --git a/dev-python/daiquiri/files/testrepository-0.0.20-test-backport1.patch b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport1.patch
new file mode 100644
index 000000000..655d2c3e7
--- /dev/null
+++ b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport1.patch
@@ -0,0 +1,16 @@
+From d3d6cac4fd42f2067c0dd81be748853f81c348fc Mon Sep 17 00:00:00 2001
+From: Robert Collins <robertc@robertcollins.net>
+Date: Sun, 12 Jul 2015 21:37:34 +1200
+Subject: [PATCH] Fix 3.3+ tests with nested classnames.
+
+--- a/testrepository/tests/ui/test_cli.py
++++ b/testrepository/tests/ui/test_cli.py
+@@ -157,7 +157,7 @@ def method(self):
+ self.assertThat(ui._stdout.buffer.getvalue().decode('utf8'),
+ DocTestMatches("""\
+ ======================================================================
+-FAIL: testrepository.tests.ui.test_cli.Case.method
++FAIL: testrepository.tests.ui.test_cli...Case.method
+ ----------------------------------------------------------------------
+ ...Traceback (most recent call last):...
+ File "...test_cli.py", line ..., in method
diff --git a/dev-python/daiquiri/files/testrepository-0.0.20-test-backport2.patch b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport2.patch
new file mode 100644
index 000000000..69d591c2f
--- /dev/null
+++ b/dev-python/daiquiri/files/testrepository-0.0.20-test-backport2.patch
@@ -0,0 +1,49 @@
+From e2f84ae6b2bcf89221613056d0c45dd308f46d62 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jelmer=20Vernoo=C4=B3?= <jelmer@jelmer.uk>
+Date: Thu, 5 Apr 2018 01:02:40 +0100
+Subject: [PATCH] Fix the testrepository tests with newer versions of
+ testtools.
+
+--- a/testrepository/tests/commands/test_failing.py
++++ b/testrepository/tests/commands/test_failing.py
+@@ -90,7 +90,7 @@ class TestCommand(ResourcedTestCase):
+ finally:
+ log.stopTestRun()
+ self.assertEqual(
+- log._events, [
++ [tuple(ev) for ev in log._events], [
+ ('startTestRun',),
+ ('status', 'failing', 'inprogress', None, True, None, None, False,
+ None, None, Wildcard),
+--- a/testrepository/tests/test_repository.py
++++ b/testrepository/tests/test_repository.py
+@@ -113,9 +113,10 @@ class FailingCase:
+ def run(self, result):
+ result.startTest(self)
+ result.addError(
+- self, None, details={'traceback': content.text_content("")})
++ self, None, details={'traceback': content.text_content("tb")})
+ result.stopTest(self)
+
++
+ def make_test(id, should_pass):
+ """Make a test."""
+ if should_pass:
+@@ -409,7 +410,7 @@ class TestRepositoryContract(ResourcedTestCase):
+ finally:
+ log.stopTestRun()
+ self.assertEqual(
+- log._events, [
++ [tuple(ev) for ev in log._events], [
+ ('startTestRun',),
+ ('status',
+ 'testrepository.tests.test_repository.Case.method',
+@@ -465,7 +466,7 @@ class TestRepositoryContract(ResourcedTestCase):
+ finally:
+ log.stopTestRun()
+ self.assertEqual(
+- log._events,
++ [tuple(ev) for ev in log._events],
+ [
+ ('startTestRun',),
+ ('status',
diff --git a/dev-python/daiquiri/metadata.xml b/dev-python/daiquiri/metadata.xml
new file mode 100644
index 000000000..e0e18bf58
--- /dev/null
+++ b/dev-python/daiquiri/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+The daiquiri library provides an easy way to configure logging. It also provides some custom formatters and handlers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jd/daiquiri</remote-id>
+ <remote-id type="pypi">daiquiri</remote-id>
+ </upstream>
+</pkgmetadata>