aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-10-10 15:09:59 +0200
committerDavid Roman <davidroman96@gmail.com>2023-10-10 15:10:24 +0200
commitc0576e741cf932b892f033e509433416d9dea7e9 (patch)
tree05f786e1c079292db62121f09f6cea456a8687c5 /dev-python/adb-shell
parentx11-themes/phinger-xcursors: treeclean (diff)
downloadguru-c0576e741cf932b892f033e509433416d9dea7e9.tar.gz
guru-c0576e741cf932b892f033e509433416d9dea7e9.tar.bz2
guru-c0576e741cf932b892f033e509433416d9dea7e9.zip
dev-python/adb-shell: add missing RDEPEND
Closes: https://bugs.gentoo.org/914216 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/adb-shell')
-rw-r--r--dev-python/adb-shell/adb-shell-0.4.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/adb-shell/adb-shell-0.4.4-r1.ebuild b/dev-python/adb-shell/adb-shell-0.4.4-r1.ebuild
new file mode 100644
index 000000000..03d3f5ceb
--- /dev/null
+++ b/dev-python/adb-shell/adb-shell-0.4.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of ADB with shell and FileSync functionality."
+HOMEPAGE="https://pypi.org/project/adb-shell/ https://github.com/JeffLIrion/adb_shell"
+SRC_URI="https://github.com/JeffLIrion/adb_shell/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/adb_shell-${PV}"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/libusb1[${PYTHON_USEDEP}]
+
+)"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+distutils_enable_tests unittest