aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-08-06 16:06:58 +0400
committerDavid Roman <davidroman96@gmail.com>2024-08-09 14:20:48 +0200
commitf840bd03ca71b507058b4f3bbf5a2a29bb6475b9 (patch)
tree168921c29eaa46b3a196c0cf4dabf9433dfd674a /dev-php
parentlicenses: add MIT-fpdf (diff)
downloadguru-f840bd03ca71b507058b4f3bbf5a2a29bb6475b9.tar.gz
guru-f840bd03ca71b507058b4f3bbf5a2a29bb6475b9.tar.bz2
guru-f840bd03ca71b507058b4f3bbf5a2a29bb6475b9.zip
dev-php/fpdf: new package, add 1.86
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru> Closes: https://github.com/gentoo/guru/pull/221 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/fpdf/Manifest1
-rw-r--r--dev-php/fpdf/fpdf-1.86.ebuild33
-rw-r--r--dev-php/fpdf/metadata.xml25
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/fpdf/Manifest b/dev-php/fpdf/Manifest
new file mode 100644
index 000000000..346b0f7ab
--- /dev/null
+++ b/dev-php/fpdf/Manifest
@@ -0,0 +1 @@
+DIST fpdf186.tgz 118080 BLAKE2B c4dc7bd3a2169ccd61fae9b99f91b7904237b81d7d72cdcb5cf5dceb63b01d73dabed2cead145ec3176e217ee5eb0244359a646abee7fc7c78b5f45f981150c7 SHA512 4894908e18d08f1ea21914c0d25ecc406875326c4bfa5f9cc9d92581e79597ec4fde173f6406bb1f84e45cef363c6b418007cf6e15c8bb8e941d925840c9ab96
diff --git a/dev-php/fpdf/fpdf-1.86.ebuild b/dev-php/fpdf/fpdf-1.86.ebuild
new file mode 100644
index 000000000..a3e5aefe0
--- /dev/null
+++ b/dev-php/fpdf/fpdf-1.86.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# shellcheck disable=SC2034
+EAPI=8
+
+MY_PV="$(ver_rs 1 '')"
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="FPDF is a PHP class which allows to generate PDF files with pure PHP"
+HOMEPAGE="http://www.fpdf.org/"
+SRC_URI="http://www.fpdf.org/en/dl.php?v=${MY_PV}&f=tgz -> ${MY_P}.tgz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT-fpdf"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="dev-lang/php:*[gd,zlib]"
+
+DOCS=( install.txt )
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r ./*.php font/ makefont/
+
+ if use doc; then
+ docinto html
+ dodoc -r changelog.htm fpdf.css FAQ.htm html/ tutorial/
+ fi
+}
diff --git a/dev-php/fpdf/metadata.xml b/dev-php/fpdf/metadata.xml
new file mode 100644
index 000000000..822e5c4c2
--- /dev/null
+++ b/dev-php/fpdf/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zdanevich.vitaly@ya.ru</email>
+ <name>Vitaly Zdanevich</name>
+ </maintainer>
+ <longdescription>
+FPDF is a PHP class which allows to generate PDF files with pure PHP, that is to say without using the PDFlib library. F from FPDF stands for Free: you may use it for any kind of usage and modify it to suit your needs.
+
+FPDF has other advantages: high level functions. Here is a list of its main features:
+
+* Choice of measure unit, page format and margins
+* Page header and footer management
+* Automatic page break
+* Automatic line break and text justification
+* Image support (JPEG, PNG and GIF)
+* Colors
+* Links
+* TrueType, Type1 and encoding support
+* Page compression
+
+FPDF requires no extension (except Zlib to enable compression and GD for GIF support). The latest version requires at least PHP 5.1.
+ </longdescription>
+</pkgmetadata>