aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-04-01 20:14:34 +0800
committerHuang Rui <vowstar@gmail.com>2022-04-01 20:14:34 +0800
commit9b056c139a7f3c573312c8f92f7b3194f25a9137 (patch)
tree7aecd73d0c32f139d411b8c42d6ca96677553d62 /dev-libs/libthai
parentsys-libs/libnvidia-container: drop old (diff)
downloadguru-9b056c139a7f3c573312c8f92f7b3194f25a9137.tar.gz
guru-9b056c139a7f3c573312c8f92f7b3194f25a9137.tar.bz2
guru-9b056c139a7f3c573312c8f92f7b3194f25a9137.zip
dev-libs/libthai: bump to 0.1.29
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'dev-libs/libthai')
-rw-r--r--dev-libs/libthai/Manifest1
-rw-r--r--dev-libs/libthai/libthai-0.1.29.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libthai/Manifest b/dev-libs/libthai/Manifest
index 5692d8ba8..88999ca6b 100644
--- a/dev-libs/libthai/Manifest
+++ b/dev-libs/libthai/Manifest
@@ -1 +1,2 @@
DIST libthai-0.1.28.tar.gz 766571 BLAKE2B 085c59b626a4191b90e0bcf738396b701a93af66f5a92b24934b76435ed91ddbd2f394e5ab1574f2e29cbec3daeb82911de153fb20c9bb77a9875e511a2289a7 SHA512 3a5f8766e3ad1484bb01a58a800667ea0b8b805158e7b574132455bd5a703bf19f4e46db8cb8fe4a75a380d88b6343234fa10dda003dcb2a8452a21acc4b8cf8
+DIST libthai-0.1.29.tar.gz 776713 BLAKE2B f41232ac1d0d596debaf282885a01a63ba8657f8adb4f0a588d845b32132440550fc79547f37e76e5340787cfc6e6d9456ad5340a912f39fefd1fbff5a213091 SHA512 2611f855ba10516897b73eaddf2bd878d82fbedebbeff4f96a2ce190f2eb66f0c9915e90752a653fa6b41de1ec673d8222004aa31e8d27119abb6ff8566dbff3
diff --git a/dev-libs/libthai/libthai-0.1.29.ebuild b/dev-libs/libthai/libthai-0.1.29.ebuild
new file mode 100644
index 000000000..a57b377df
--- /dev/null
+++ b/dev-libs/libthai/libthai-0.1.29.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A a set of Thai language support routines"
+HOMEPAGE="https://github.com/tlwg/libthai"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tlwg/${PN}.git"
+else
+ SRC_URI="https://github.com/tlwg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="dev-libs/libdatrie"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+ # Fixed version if in non git project
+ echo ${PV} > VERSION
+ # From upstreams autogen.sh, to make it utilize the autotools eclass
+ # Here translate the autogen.sh, equivalent to the following code
+ # > sh autogen.sh
+ # Fix html doc path
+ sed -i -e "s|share/doc/libthai/html|share/doc/libthai-${PV}/html|g" configure.ac || die
+ _elibtoolize --force
+ eaclocal
+ eautomake --add-missing
+ # Not allow git-version-gen does refresh
+ eautoconf
+}