aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorItai Ferber <itai@itaiferber.net>2024-08-10 11:57:24 -0400
committerItai Ferber <itai@itaiferber.net>2024-08-10 11:57:24 -0400
commit4ea75ccb1674776ca811a0b2df41c83ea48fb9a2 (patch)
treeb732354bebd3b77d26ed8cf5041ac8695378efa2 /dev-lang
parentdev-lang/swift: fix build-time dependencies (diff)
downloadguru-4ea75ccb1674776ca811a0b2df41c83ea48fb9a2.tar.gz
guru-4ea75ccb1674776ca811a0b2df41c83ea48fb9a2.tar.bz2
guru-4ea75ccb1674776ca811a0b2df41c83ea48fb9a2.zip
dev-lang/swift: ebuild correctness fixes
Signed-off-by: Itai Ferber <itai@itaiferber.net>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swift/swift-5.10.1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/swift/swift-5.10.1.ebuild b/dev-lang/swift/swift-5.10.1.ebuild
index a53eb87d5..4037a47c9 100644
--- a/dev-lang/swift/swift-5.10.1.ebuild
+++ b/dev-lang/swift/swift-5.10.1.ebuild
@@ -49,10 +49,10 @@ SRC_URI="
https://github.com/unicode-org/icu/archive/refs/tags/release-69-1.tar.gz -> icu-69.1.tar.gz
"
-PATCHES="
- ${FILESDIR}/${P}-link-with-lld.patch
- ${FILESDIR}/${P}-llbuild-link-ncurses-tinfo-gentoo.patch
-"
+PATCHES=(
+ "${FILESDIR}/${P}-link-with-lld.patch"
+ "${FILESDIR}/${P}-llbuild-link-ncurses-tinfo-gentoo.patch"
+)
S="${WORKDIR}"
LICENSE="Apache-2.0"
@@ -234,7 +234,7 @@ src_install() {
# `libicudataswift.so.69.1` has an empty `DT_RUNPATH`, which fails
# `rpath_security_checks`. It contains only data, so we can remove its rpath
# altogether.
- patchelf --remove-rpath "${S}/stage2/usr/lib/swift/linux/libicudataswift.so.69.1"
+ patchelf --remove-rpath "${S}/stage2/usr/lib/swift/linux/libicudataswift.so.69.1" || die
# The Swift build output is intended to be self-contained, and is
# _significantly_ easier to leave as-is than attempt to splat onto the
@@ -249,6 +249,7 @@ src_install() {
# exposed externally, so we'll just symlink Swift-specific binaries into
# `/usr/bin`. (The majority of executables don't need to be exposed as
# `swift <command>` calls `swift-<command>` directly.)
+ local bin
for bin in swift swiftc sourcekit-lsp; do
dosym -r "${dest_dir}/usr/bin/${bin}" "/usr/bin/${bin}"
done