aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Price <sprice623@aol.com>2023-08-21 13:52:01 -0400
committerSeth Price <sprice623@aol.com>2023-08-21 13:52:01 -0400
commit001e6b11d6b23e2df03491dacda37b85e6300fff (patch)
treebff112e7554ec5eb7fbdfcc207647c0ff98c65f0 /dev-lang
parentdev-lang/cc65: use .tar.gz dist instead of Git (diff)
downloadguru-001e6b11d6b23e2df03491dacda37b85e6300fff.tar.gz
guru-001e6b11d6b23e2df03491dacda37b85e6300fff.tar.bz2
guru-001e6b11d6b23e2df03491dacda37b85e6300fff.zip
dev-lang/cc65: add 9999
Signed-off-by: Seth Price <sprice623@aol.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cc65/cc65-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-lang/cc65/cc65-9999.ebuild b/dev-lang/cc65/cc65-9999.ebuild
new file mode 100644
index 000000000..f7f4043e7
--- /dev/null
+++ b/dev-lang/cc65/cc65-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022, 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Cross-development package for 65(C)02 systems"
+HOMEPAGE="https://cc65.github.io/"
+EGIT_REPO_URI="https://github.com/cc65/cc65.git"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+}